]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Fix rpm relocation macro usage
authorMark Hatle <mark.hatle@windriver.com>
Wed, 28 Nov 2012 21:37:39 +0000 (15:37 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:31 +0000 (12:30 +0000)
When RPM is setup to dynamically reconfigure itself at runtime, we need
to avoid hard coded settings for _usrlibrpm and _etcrpm.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/rpm/rpm/rpm-reloc-macros.patch [new file with mode: 0644]
meta/recipes-devtools/rpm/rpm_5.4.9.bb

diff --git a/meta/recipes-devtools/rpm/rpm/rpm-reloc-macros.patch b/meta/recipes-devtools/rpm/rpm/rpm-reloc-macros.patch
new file mode 100644 (file)
index 0000000..33ec8e2
--- /dev/null
@@ -0,0 +1,31 @@
+macros: Use dyanmic config vs hard coded settings
+
+When the dynamic, runtime relocation is enables we need to make sure that the 
+RPM macro file does not override the dynamic settings.  Fix this by forcing the
+dynamic version to be used in all cases.
+
+Upstream-Status: Inapproriate (OpenEmbedded specific)
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+Index: rpm-5.4.9/macros/macros.in
+===================================================================
+--- rpm-5.4.9.orig/macros/macros.in
++++ rpm-5.4.9/macros/macros.in
+@@ -27,11 +27,12 @@
+ #==============================================================================
+ # ---- filesystem macros.
+ #
+-%_usr                 @usrprefix@
++%_usr                 %{_usrlibrpm}/../..
+ %_usrsrc              %{_usr}/src
+-%_var                 @varprefix@
+-%_usrlibrpm           @USRLIBRPM@
+-%_etcrpm              @SYSCONFIGDIR@
++%_var                 %{_usr}/../var
++# The dynamic relocation code sets the following two items
++#%_usrlibrpm          @USRLIBRPM@
++#%_etcrpm             @SYSCONFIGDIR@
+ %__objext             @objext@
+ %__libext             @libext@
index ccf079a694ed08feffee2b07b20c008a52f4ebf8..59f3eef276e155aa11f04f281352fb68f69cabbe 100644 (file)
@@ -43,7 +43,7 @@ LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
 DEPENDS = "libpcre attr acl popt ossp-uuid file bison-native"
-PR = "r56"
+PR = "r57"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...
@@ -82,6 +82,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;ex
           file://rpm-db_buffer_small.patch \
           file://rpm-py-init.patch \
           file://python-rpm-rpmsense.patch \
+          file://rpm-reloc-macros.patch \
          "
 
 SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768"