]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk+-native: add gtk-update-icon-cache wrapper
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Mon, 17 Dec 2012 12:32:43 +0000 (14:32 +0200)
committerSaul Wold <sgw@linux.intel.com>
Wed, 19 Dec 2012 07:48:22 +0000 (23:48 -0800)
This is needed in order to point where the pixbuf loaders.cache is
located and avoid warnings like the one below that appear when the
sstate is fetched from a remote machine:

(gtk-update-icon-cache:8913): GdkPixbuf-WARNING **: Cannot open pixbuf
loader module file '/REMOTE/MACHINE/PATH/loaders.cache': No such file or directory

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-gnome/gtk+/gtk+_2.24.14.bb

index 465f2b7f6a39fc87397151f2f69e48c0b4256712..553196a1507a63ed403d66ef70889d96b12cc413 100644 (file)
@@ -42,6 +42,11 @@ BBCLASSEXTEND = "native"
 RRECOMMENDS_${PN}_class-native = ""
 DEPENDS_class-native = "glib-2.0-native atk-native pango-native cairo-native gdk-pixbuf-native"
 
+do_install_append_class-native () {
+       create_wrapper ${D}/${bindir}/gtk-update-icon-cache \
+               GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
+}
+
 python populate_packages_prepend () {
     prologue = d.getVar("postinst_prologue", True)