]> code.ossystems Code Review - openembedded-core.git/commitdiff
libuser: enable documentation
authorScott Garman <scott.a.garman@intel.com>
Wed, 23 Feb 2011 22:14:12 +0000 (14:14 -0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 1 Mar 2011 11:46:41 +0000 (11:46 +0000)
Added popt to DEPENDS. This fixes the following build error:

apps/luserdel.c:25:18: fatal error: popt.h: No such file or directory

Remove patch and configure flag which had disabled doc generation

Add docbook-utils-native and linuxdoc-tools-native to DEPENDS

This fixes [BUGID #213]

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-extended/libuser/libuser-0.57.1/disable-sgml-doc.patch [deleted file]
meta/recipes-extended/libuser/libuser_0.57.1.bb

diff --git a/meta/recipes-extended/libuser/libuser-0.57.1/disable-sgml-doc.patch b/meta/recipes-extended/libuser/libuser-0.57.1/disable-sgml-doc.patch
deleted file mode 100644 (file)
index a2017c5..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Disable generating docs from sgml, which requries linuxdoc-tools.
-
-Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
-Index: libuser-0.56.16/docs/Makefile.am
-===================================================================
---- libuser-0.56.16.orig/docs/Makefile.am      2010-08-12 13:29:43.000000000 +0800
-+++ libuser-0.56.16/docs/Makefile.am   2010-08-12 13:29:51.000000000 +0800
-@@ -14,8 +14,8 @@
- sgml/libuser.txt: $(srcdir)/sgml/libuser.sgml
-       [ -d sgml ] || mkdir sgml
--      cd sgml; sgml2txt ../$(srcdir)/sgml/libuser.sgml
-+#     cd sgml; sgml2txt ../$(srcdir)/sgml/libuser.sgml
- sgml/libuser.html: $(srcdir)/sgml/libuser.sgml
-       [ -d sgml ] || mkdir sgml
--      cd sgml; sgml2html ../$(srcdir)/sgml/libuser.sgml
-+#     cd sgml; sgml2html ../$(srcdir)/sgml/libuser.sgml
index d2e7c3aa2e02eceb91062bfd31f50a289b786e62..2dd3f11bf7a08665d3fcef1689b15051493d39a5 100644 (file)
@@ -11,15 +11,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
 
 SECTION = "base"
 
-SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz \
-           file://disable-sgml-doc.patch;patch=1"
+SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz"
 
 SRC_URI[md5sum] = "be82c6941264d0b4bd04f95fb342ec7d"
 SRC_URI[sha256sum] = "a61289867581fa715354a3fafe09c3e481173ce0a2dcb33b04588b6ac13cead5"
-PR = "r0"
+PR = "r1"
 
-DEPENDS = "gettext libpam glib-2.0 xz-native"
+DEPENDS = "gettext popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native"
 
-EXTRA_OECONF += "--disable-gtk-doc --without-python"
+EXTRA_OECONF += "--without-python"
 
 inherit autotools