]> code.ossystems Code Review - openembedded-core.git/commitdiff
nativesdk-buildtools-perl-dummy: fix rebuilding when SDKMACHINE changes
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 9 Nov 2015 16:45:21 +0000 (16:45 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Jan 2016 16:12:56 +0000 (16:12 +0000)
This recipe produces an empty dummy package (in order to satisfy
dependencies on perl so we don't have perl within buildtools-tarball).
Because we were inheriting nativesdk here the recipe was being rebuilt,
but having forced PACKAGE_ARCH to a particular value the packages for
each architecture were stepping on eachother. Since the packages are
empty they can in fact be allarch (even though they won't actually go
into the "all" package feed). It turns out that nheriting nativesdk
wasn't actually necessary either, so drop that.

Fixes [YOCTO #8509].

(From OE-Core rev: 9b1831cf4a2940dca1d23f14dff460ff5a50a520)

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb

index d971c3ca3db3c27bb68091fb40031fb091323df1..6fb2b64f79b0031e547cf82b7b6f18dd4e1fb4d7 100644 (file)
@@ -2,9 +2,16 @@ SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
 
-inherit nativesdk
+inherit allarch
+
+python() {
+    # Put the package somewhere separate to ensure it's never used except
+    # when we want it
+    # (note that we have to do this in anonymous python here to avoid
+    # allarch.bbclass disabling itself)
+    d.setVar('PACKAGE_ARCH', 'buildtools-dummy-${SDKPKGSUFFIX}')
+}
 
-# Put it somewhere separate to ensure it's never used except when we want it
 PACKAGE_ARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
 
 PERLPACKAGES = "nativesdk-perl \