]> code.ossystems Code Review - openembedded-core.git/commitdiff
update-rc.d: Add native version, add native dependency to class, convert staging...
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:00:22 +0000 (22:00 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:00:22 +0000 (22:00 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/classes/update-rc.d.bbclass
meta/packages/update-rc.d/update-rc.d/add-verbose.patch [moved from meta/packages/update-rc.d/files/add-verbose.patch with 100% similarity]
meta/packages/update-rc.d/update-rc.d_0.7.bb

index 5a8062cc7c49834080f914b333726d8474a15f45..0c648edb4d1a1d7d83eab51e075acb0fd659f682 100644 (file)
@@ -1,4 +1,4 @@
-DEPENDS_append = " update-rc.d"
+DEPENDS_append = " update-rc.d-native"
 RDEPENDS_${PN}_append = " update-rc.d"
 
 INITSCRIPT_PARAMS ?= "defaults"
index dd370e6ff8c8603113c9514a1ca9fabbd54a077f..362f8603c4a890f8071124c228bb6392104e000b 100644 (file)
@@ -13,11 +13,10 @@ PACKAGE_ARCH = "all"
 do_compile() {
 }
 
-do_stage() {
-       install -m 0755 ${S}/update-rc.d ${STAGING_BINDIR_NATIVE}/
-}
-
+NATIVE_INSTALL_WORKS = "1"
 do_install() {
        install -d ${D}${sbindir}
        install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
 }
+
+BBCLASSEXTEND = "native"
\ No newline at end of file