]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add missing RDEPENDS of initscripts-functions
authorChen Qi <Qi.Chen@windriver.com>
Mon, 6 Jan 2014 07:27:35 +0000 (15:27 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 6 Jan 2014 16:30:00 +0000 (16:30 +0000)
Now that the initscripts-functions has been packaged separately,
packages which may use the functions script should have a runtime
dependency on it.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
17 files changed:
meta/recipes-bsp/alsa-state/alsa-state.bb
meta/recipes-bsp/apmd/apmd_3.2.2-14.bb
meta/recipes-connectivity/irda-utils/irda-utils_0.9.18.bb
meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.9.bb
meta/recipes-connectivity/openssh/openssh_6.4p1.bb
meta/recipes-connectivity/ppp/ppp_2.4.5.bb
meta/recipes-core/dbus/dbus.inc
meta/recipes-core/systemd/systemd_208.bb
meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
meta/recipes-devtools/distcc/distcc_3.1.bb
meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
meta/recipes-extended/at/at_3.1.14.bb
meta/recipes-extended/cronie/cronie_1.4.11.bb
meta/recipes-extended/rpcbind/rpcbind_0.2.1.bb
meta/recipes-extended/sysklogd/sysklogd.inc
meta/recipes-extended/xinetd/xinetd_2.3.15.bb
meta/recipes-kernel/oprofile/oprofileui-server_git.bb

index 552fcfc02222ce13b3d4d29b4250578dbf0deed9..4be74aa036228d03f8721096bf558fbd1849ed20 100644 (file)
@@ -37,7 +37,7 @@ PACKAGES += "alsa-states"
 
 RRECOMMENDS_alsa-state = "alsa-states"
 
-RDEPENDS_${PN} = "alsa-utils-alsactl"
+RDEPENDS_${PN} = "alsa-utils-alsactl initscripts-functions"
 FILES_${PN} = "${sysconfdir}/init.d ${sysconfdir}/asound.conf"
 CONFFILES_${PN} = "${sysconfdir}/asound.conf"
 
index 8c4b75eb6d0f80ce93da0f2842595801a9f6a765..d5ddc174f5d9ce26e96da7467dd74fdd79773a10 100644 (file)
@@ -8,6 +8,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://apm.h;beginline=6;endline=18;md5=7d4acc1250910a89f84ce3cc6557c4c2"
 DEPENDS = "libtool-cross"
+RDEPENDS_${PN} = "initscripts-functions"
 PR = "r2"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz;name=tarball \
index 7f216ac704b05f72e33285efdfd36b20266d49dd..59c9b6acce36e654b72a1f410d0a31c4eeaf8926 100644 (file)
@@ -24,6 +24,8 @@ inherit autotools update-rc.d
 INITSCRIPT_NAME = "irattach"
 INITSCRIPT_PARAMS = "defaults 20"
 
+RDEPENDS_${PN} += "initscripts-functions"
+
 do_compile () {
     oe_runmake -e -C irattach
     oe_runmake -e -C irdaping
index 45eacd970ef9ee75d29783a5628bcfa3d59cd387..fd44ea1b2070ae2eb9489e962f125b034dde8567 100644 (file)
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
 
 # util-linux for libblkid
 DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3"
-RDEPENDS_${PN}-client = "rpcbind bash"
-RDEPENDS_${PN} = "${PN}-client bash"
+RDEPENDS_${PN}-client = "rpcbind bash initscripts-functions"
+RDEPENDS_${PN} = "${PN}-client bash initscripts-functions"
 RRECOMMENDS_${PN} = "kernel-module-nfsd"
 
 inherit useradd
index 4f8d70aa2f79c3ac3fe4e10e0287e8543c4757e5..c61d16f6c6690b3a21b0760c1abfd906ea0d3f36 100644 (file)
@@ -122,7 +122,7 @@ FILES_${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*"
 FILES_${PN}-keygen = "${bindir}/ssh-keygen"
 
 RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen"
-RDEPENDS_${PN}-sshd += "${PN}-keygen"
+RDEPENDS_${PN}-sshd += "${PN}-keygen initscripts-functions"
 
 CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
 CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
index 52bab4fc431ce78ae3e3ad1acf41ddb9677f8d42..ed1a3910a6d491346626d8bb8f0069b310356096 100644 (file)
@@ -5,6 +5,7 @@ SECTION = "console/network"
 HOMEPAGE = "http://samba.org/ppp/"
 BUGTRACKER = "http://ppp.samba.org/cgi-bin/ppp-bugs"
 DEPENDS = "libpcap"
+RDEPENDS_${PN} = "initscripts-functions"
 LICENSE = "BSD & GPLv2+ & LGPLv2+ & PD"
 LIC_FILES_CHKSUM = "file://pppd/ccp.c;beginline=1;endline=29;md5=e2c43fe6e81ff77d87dc9c290a424dea \
                     file://pppd/plugins/passprompt.c;beginline=1;endline=10;md5=3bcbcdbf0e369c9a3e0b8c8275b065d8 \
index ae80cb054073222bae738f9582b31d4e5a8f24f3..9bdb48959e9fa47383dcca8132617ddfe166bc6c 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "AFL-2 | GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
                     file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
 DEPENDS = "expat virtual/libintl"
-RDEPENDS_dbus = "${@base_contains('DISTRO_FEATURES', 'ptest', 'dbus-ptest-ptest', '', d)}"
+RDEPENDS_dbus = "${@base_contains('DISTRO_FEATURES', 'ptest', 'dbus-ptest-ptest', '', d)} initscripts-functions"
 RDEPENDS_dbus_class-native = ""
 RDEPENDS_dbus_class-nativesdk = ""
 
index dcf68dcde3d307f1b36214b1ae4a8cfc54976eba..6590235ca77fa8899b0d53b1cce9e16d5ff90dd8 100644 (file)
@@ -229,7 +229,7 @@ PACKAGES =+ "udev-dbg udev udev-utils udev-hwdb"
 
 FILES_udev-dbg += "/lib/udev/.debug"
 
-RDEPENDS_udev += "udev-utils"
+RDEPENDS_udev += "udev-utils initscripts-functions"
 RPROVIDES_udev = "hotplug"
 RRECOMMENDS_udev += "udev-hwdb"
 
index dd25f7153057ea5b4a3c8d27c936b71be7bb6ff4..a84448aadb7f0c7960d31f76d0fc81eebd9d3c5b 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://COPYRIGHT;endline=15;md5=349c872e0066155e1818b786938876a4"
 PR = "r11"
 
-RDEPENDS_${PN} = "${PN}-inittab"
+RDEPENDS_${PN} = "${PN}-inittab initscripts-functions"
 
 SRC_URI = "http://download.savannah.gnu.org/releases-noredirect/sysvinit/sysvinit-${PV}.tar.bz2 \
            file://install.patch \
index 5c889fa9bc518171d8ab822439665bd9b0a6a500..e351a58192c1e1cf1128c931386d33ca8acca3e7 100644 (file)
@@ -6,6 +6,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 DEPENDS = "avahi"
+RDEPENDS_${PN} = "initscripts-functions"
 
 GTKCONFIG = "gtk"
 GTKCONFIG_libc-uclibc = ""
index 1eb0021eeca76439c72263f4c794d98f818507ba..6d0fbb6c36d16a5de1f7db8b93ea3e8cec81fceb 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent.git \
           "
 
 DEPENDS = "util-linux openssl"
-RDEPENDS_${PN} = "bash"
+RDEPENDS_${PN} = "bash initscripts-functions"
 
 S = "${WORKDIR}/git"
 
index 1eb18b3028840ce20c3a5dd8135803845be89f34..0a1315726e2cf92066fc3ecf268e23903a24f76d 100644 (file)
@@ -7,9 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
 DEPENDS = "flex flex-native \
            ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 
-VIRTUAL-RUNTIME_initscripts ?= "initscripts"                                                                                                                 
 RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \
-                  ${VIRTUAL-RUNTIME_initscripts} \
+                  initscripts-functions \
 "
 
 PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
index d98d0d9167ab50893b22fb8b70b6348f978dde6c..c6981812801c1177311a930598dec4c357c32fd1 100644 (file)
@@ -39,6 +39,8 @@ PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,${PAM_DEPS}"
 INITSCRIPT_NAME = "crond"
 INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
 
+RDEPENDS_${PN} = "initscripts-functions"
+
 USERADD_PACKAGES = "${PN}"
 GROUPADD_PARAM_${PN} = "--system crontab"
 
index 6043501b5b3549f73694bab911ac8f3e3504af42..c1c34037c6d43dfb79d1f4f16dfab5336a0d2217 100644 (file)
@@ -33,6 +33,8 @@ PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
 INITSCRIPT_NAME = "rpcbind"
 INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
 
+RDEPENDS_${PN} = "initscripts-functions"
+
 SYSTEMD_SERVICE_${PN} = "rpcbind.service"
 SYSTEMD_AUTO_ENABLE = "disable"
 
index 3a518103ea75d06752ccde2a71d85feb26855984..ef7004429c6bbc753c403fdc8920760a76ce546d 100644 (file)
@@ -24,6 +24,8 @@ SRC_URI_append_e500v2 = " file://no-vectorization.patch"
 INITSCRIPT_NAME = "syslog"
 CONFFILES_${PN} = "${sysconfdir}/syslog.conf.${BPN}"
 
+RDEPENDS_${PN} = "initscripts-functions"
+
 CFLAGS_append = " -DSYSV"
 
 do_install () {
index 1928949e94d4b9d2928ec2442c017459877eab08..c43892c719ad806253a9826a3e9a0d1fdd3fb153 100644 (file)
@@ -7,6 +7,7 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
 
 DEPENDS = ""
+RDEPENDS_${PN} = "initscripts-functions"
 PR = "r2"
 
 SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
index dbb559965a8e52116e0f349a16df68e2ea77ec96..63f33e2e605b9ac6793b3fd337abec2431faa8ae 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI = "git://git.yoctoproject.org/oprofileui \
 
 EXTRA_OECONF += "--disable-client --enable-server"
 
-RDEPENDS_${PN} = "oprofile"
+RDEPENDS_${PN} = "oprofile initscripts-functions"
 
 do_install_append() {
        install -d ${D}${sysconfdir}/init.d