]> code.ossystems Code Review - openembedded-core.git/commitdiff
go.bbclass: Add "ldflags" to QA skip list
authorOtavio Salvador <otavio@ossystems.com.br>
Wed, 13 Sep 2017 17:54:07 +0000 (14:54 -0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 13 Sep 2017 21:12:19 +0000 (22:12 +0100)
Currently every Go package will end with GNU_HASH in the ELF binary
however adding it to every recipe is cumbersome so instead we handle
that here.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/go.bbclass
meta/recipes-devtools/go/go-dep_0.3.0.bb

index d805dc2713736087cdd64b66044fa8d5eb561e9e..4af148e3024d3f965d23aff3dfc2f16e1991ae77 100644 (file)
@@ -109,3 +109,5 @@ EXPORT_FUNCTIONS do_unpack do_configure do_compile do_install
 
 FILES_${PN}-dev = "${libdir}/go/src"
 FILES_${PN}-staticdev = "${libdir}/go/pkg"
+
+INSANE_SKIP_${PN} += "ldflags"
index 5e4544a104770d17f0066669596b21a0154bff4e..abfeb4837095477e2813b3b2c1b1109063d26ceb 100644 (file)
@@ -13,6 +13,4 @@ inherit go
 
 GO_INSTALL = "${GO_IMPORT}/cmd/dep"
 
-INSANE_SKIP_${PN} += "ldflags"
-
 RDEPENDS_${PN}-dev += "bash"