]> code.ossystems Code Review - openembedded-core.git/commitdiff
gawk: fix command location in ptest script
authorLi Wang <li.wang@windriver.com>
Fri, 25 May 2018 02:48:13 +0000 (10:48 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 May 2018 20:06:03 +0000 (21:06 +0100)
* Correct the command location in ptest scripts such as
  update the line "#!/bin/awk -f" to "#!/usr/bin/awk -f" in the
  file /usr/lib64/gawk/ptest/test/fcall_exit2.awk belongs
  to package gawk-ptest and the line "#!/usr/local/bin/gawk -f"
  to "#!/usr/bin/gawk -f" in the file
  /usr/lib64/gawk/ptest/test/fnarydel.awk

Signed-off-by: Li Wang <li.wang@windriver.com>
Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/gawk/gawk_4.2.1.bb

index 6b9935767b4444910ca0913bdfd15d4f3fa040cd..966375239470b8eb5e54a3bbc8243197b78502b8 100644 (file)
@@ -43,6 +43,8 @@ do_install_ptest() {
        for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests inclib.awk; \
          do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
        done
+       sed -i -e 's|/usr/local/bin|${bindir}|g' \
+           -e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk
 }
 
 BBCLASSEXTEND = "native nativesdk"