]> code.ossystems Code Review - openembedded-core.git/commitdiff
fakeroot: Clean up and convert to BBCLASSEXTEND
authorRichard Purdie <rpurdie@linux.intel.com>
Sat, 3 Jan 2009 18:33:03 +0000 (18:33 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Sat, 3 Jan 2009 18:33:03 +0000 (18:33 +0000)
meta/packages/fakeroot/fakeroot-native_1.9.4.bb [deleted file]
meta/packages/fakeroot/fakeroot/configure-libtool.patch [moved from meta/packages/fakeroot/files/configure-libtool.patch with 100% similarity]
meta/packages/fakeroot/fakeroot_1.9.4.bb
meta/packages/fakeroot/files/fix-prefix.patch [deleted file]

diff --git a/meta/packages/fakeroot/fakeroot-native_1.9.4.bb b/meta/packages/fakeroot/fakeroot-native_1.9.4.bb
deleted file mode 100644 (file)
index 77d6f58..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-require fakeroot_${PV}.bb
-
-RDEPENDS="util-linux-native"
-
-SRC_URI += "file://fix-prefix.patch;patch=1 "
-S = "${WORKDIR}/fakeroot-${PV}"
-
-inherit native
-
-EXTRA_OECONF = " --program-prefix="
-
-# Compatability for the rare systems not using or having SYSV
-python () {
-    if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
-        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
-}
-
-do_stage_append () {
-    oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
-}
-
index aaf696d79d115f942a9acf36f90f69de570e2406..04219519edb5ce22f45333d39385cb35e912808b 100644 (file)
@@ -4,15 +4,22 @@ SECTION = "base"
 LICENSE = "GPL"
 # fakeroot needs getopt which is provided by the util-linux package
 RDEPENDS = "util-linux"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
            file://configure-libtool.patch;patch=1"
            
-inherit autotools
+inherit autotools_stage
 
-do_stage() {
+do_stage_append() {
         install -d ${STAGING_INCDIR}/fakeroot
         install -m 644 *.h ${STAGING_INCDIR}/fakeroot
-        autotools_stage_all
 }
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+    if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+        bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
+}
+
+BBCLASSEXTEND = "native"
\ No newline at end of file
diff --git a/meta/packages/fakeroot/files/fix-prefix.patch b/meta/packages/fakeroot/files/fix-prefix.patch
deleted file mode 100644 (file)
index 3884aca..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- fakeroot-1.2.13/scripts/fakeroot.in~fix-prefix
-+++ fakeroot-1.2.13/scripts/fakeroot.in
-@@ -15,8 +15,8 @@
- }
- # strip /bin/fakeroot to find install prefix
--PREFIX=@prefix@
--BINDIR=@bindir@
-+BINDIR=`dirname $0`
-+PREFIX=`dirname ${BINDIR}`
-     
- LIB=lib@fakeroot_transformed@.so.0
- PATHS=@libdir@:${PREFIX}/lib64/libfakeroot:${PREFIX}/lib32/libfakeroot