]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysstat: fix CVE-2019-19725
authorAnuj Mittal <anuj.mittal@intel.com>
Wed, 11 Dec 2019 23:10:42 +0000 (07:10 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 31 Dec 2019 10:36:31 +0000 (10:36 +0000)
(From OE-Core rev: 2bf6fdc460526feb0955b3b789e7be78f6e8ec4a)

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/sysstat/sysstat/CVE-2019-19725.patch [new file with mode: 0644]
meta/recipes-extended/sysstat/sysstat_12.1.6.bb

diff --git a/meta/recipes-extended/sysstat/sysstat/CVE-2019-19725.patch b/meta/recipes-extended/sysstat/sysstat/CVE-2019-19725.patch
new file mode 100644 (file)
index 0000000..2aa1272
--- /dev/null
@@ -0,0 +1,28 @@
+From a5c8abd4a481ee6e27a3acf00e6d9b0f023e20ed Mon Sep 17 00:00:00 2001
+From: Sebastien GODARD <sysstat@users.noreply.github.com>
+Date: Mon, 9 Dec 2019 17:54:07 +0100
+Subject: [PATCH] Fix #242: Double free in check_file_actlst()
+
+Avoid freeing buffer() twice.
+
+Signed-off-by: Sebastien GODARD <sysstat@users.noreply.github.com>
+
+Upstream-Status: Backport [https://github.com/sysstat/sysstat/commit/a5c8abd4a481ee6e27a3acf00e6d9b0f023e20ed]
+CVE: CVE-2019-19725
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ sa_common.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/sa_common.c b/sa_common.c
+index cf52aefe..856a3715 100644
+--- a/sa_common.c
++++ b/sa_common.c
+@@ -2153,6 +2153,7 @@ void check_file_actlst(int *ifd, char *dfile, struct activity *act[], uint64_t f
+       }
+       free(buffer);
++      buffer = NULL;
+       /* Check that at least one activity selected by the user is available in file */
+       for (i = 0; i < NR_ACT; i++) {
index 362888d506a4c8d1751cbcd6b0f5e6f1194b0013..674addb4dfea23fb0336104b721174a77c228d49 100644 (file)
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a23a74b3f4caf9616230789d94217acb"
 
 SRC_URI += "file://0001-Include-needed-headers-explicitly.patch \
            file://0001-Fix-232-Memory-corruption-bug-due-to-Integer-Overflo.patch \
+            file://CVE-2019-19725.patch \
 "
 
 SRC_URI[md5sum] = "d8e3bbb9c873dd370f6d33664e326570"