]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev-extraconf: Add rule adding input devices to input group
authorDarren Hart <dvhart@linux.intel.com>
Wed, 3 Apr 2013 19:49:40 +0000 (12:49 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Apr 2013 13:00:15 +0000 (14:00 +0100)
Fixes [YOCTO 4164](2/3)

Add all /dev/input/* devices to the input group with g+rw.  This is
needed for rootless X without adding a security hole by making the
device o+rw.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Cc: Saul Wold <sgw@linux.intel.com>
Cc: Radu Moisan <radu.moisan@intel.com>
Cc: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/udev/udev-extraconf/localextra.rules
meta/recipes-core/udev/udev-extraconf_1.0.bb

index 4eaa8ca9b043297a752488d7e178e43c7ba91efa..3d51d3e395d45a2a3767ab011480f8843943e5fa 100644 (file)
@@ -19,3 +19,5 @@ KERNEL=="rtc0", SYMLINK+="rtc"
 #The first framebuffer is symlinked to /dev/fb
 KERNEL=="fb0",  SYMLINK+="fb"
 
+# Make all input devices read-write to the input group
+SUBSYSTEM=="input", GROUP="input", MODE="660"
index 2c4a4f1976c431c21baf7c8087421c5ed4b68a51..ea95a600679e5537af3ee634de68c7b1c2653fea 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
 
 inherit allarch
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = " \
        file://automount.rules \