]> code.ossystems Code Review - openembedded-core.git/commitdiff
classes: Split rpm feeds by PACKAGE_ARCH
authorRichard Purdie <richard@openedhand.com>
Thu, 2 Oct 2008 15:21:36 +0000 (15:21 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 2 Oct 2008 15:21:36 +0000 (15:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5381 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/classes/package_rpm.bbclass

index aa22dd76684f217ea6871bc05a4f9e7ed642723b..ae87bbff035757976c50b4149002c9b055128d75 100644 (file)
@@ -125,7 +125,7 @@ python write_specfile() {
 
        # move the rpm into the pkgoutdir
        rpm = bb.data.expand('${RPMBUILDPATH}/RPMS/${TARGET_ARCH}/${PKG}-${RPMPV}-${PR}.${TARGET_ARCH}.rpm', d)
-       outrpm = bb.data.expand('${DEPLOY_DIR_RPM}/${PKG}-${RPMPV}-${PR}.${TARGET_ARCH}.rpm', d)
+       outrpm = bb.data.expand('${DEPLOY_DIR_RPM}/${PACKAGE_ARCH}/${PKG}-${RPMPV}-${PR}.${TARGET_ARCH}.rpm', d)
        bb.movefile(rpm, outrpm)
 }
 
@@ -187,7 +187,7 @@ python do_package_rpm () {
 
                bb.data.update_data(localdata)
                basedir = os.path.join(os.path.dirname(root))
-               pkgoutdir = outdir
+               pkgoutdir = os.path.join(outdir, bb.data.getVar('PACKAGE_ARCH', localdata, 1))
                bb.mkdirhier(pkgoutdir)
                bb.data.setVar('OUTSPECFILE', os.path.join(workdir, "%s.spec" % pkg), localdata)
                # Save the value of RPMBUILD expanded into the new dictonary so any