]> code.ossystems Code Review - openembedded-core.git/commitdiff
bjam-native: don't do debug builds
authorRoss Burton <ross@burtonini.com>
Tue, 29 Sep 2020 22:16:37 +0000 (23:16 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Oct 2020 22:11:47 +0000 (23:11 +0100)
Previously this recipe was changed to do debug builds because otherwise insane
warns that the binary is already stripped.

However, debug builds for boost.build also pass -O0.  It turns out that given
how large Boost is (or, how bad boost.build is) doing a release build with -O3
knocks a third off the walltime for a Boost package in my test, mainly by reducing
how long it spends deciding that nothing needs to be rebuilt in do_install:

  PKG      TASK        ABSDIFF  RELDIFF  WALLTIME1 -> WALLTIME2
  boost    do_install  -330.7s   -69.2%     477.6s -> 146.9s
  boost    do_compile    -7.1s    -2.7%     269.3s -> 262.2s

Replace debug mode with INSANE_SKIP=already-stripped.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/boost/bjam-native_1.74.0.bb
meta/recipes-support/boost/files/0001-Build-debug-version-of-bjam.patch [deleted file]
meta/recipes-support/boost/files/0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch [deleted file]

index d843eb038cb503c29686dc2456899f1de88ac4c3..c0eeed60b0681e6f1af571d0993cabf970657dd0 100644 (file)
@@ -5,16 +5,14 @@ SECTION = "devel"
 
 inherit native
 
-SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
-            file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
-           "
-
 do_compile() {
     ./bootstrap.sh --with-toolset=gcc
 }
 
 do_install() {
     install -d ${D}${bindir}/
-    # install unstripped version for bjam
-    install -c -m 755 b2 ${D}${bindir}/bjam
+    install b2 ${D}${bindir}/bjam
 }
+
+# The build is either release mode (pre-stripped) or debug (-O0).
+INSANE_SKIP_${PN} = "already-stripped"
diff --git a/meta/recipes-support/boost/files/0001-Build-debug-version-of-bjam.patch b/meta/recipes-support/boost/files/0001-Build-debug-version-of-bjam.patch
deleted file mode 100644 (file)
index c6dcee9..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 19c117c3d1388654da484e26afb3fb6c3e4181a9 Mon Sep 17 00:00:00 2001
-From: Daniel Klauer <daniel.klauer@gin.de>
-Date: Tue, 30 Jul 2019 11:39:09 +0200
-Subject: [PATCH] Build debug version of bjam
-
-bjam is stripped by default, this causes QA warning while stripping it
-from do_populate_sysroot():
-
-  WARNING: File '.../tmp/sysroots/x86_64-linux/usr/bin/bjam' \
-    from bjam-native was already stripped, \
-    this will prevent future debugging!
-
-The JAM scripts allow to build unstripped version with '--debug'. Just
-build and install the bjam.debug to stop bjam from being stripped in
-compile step.
-
-Upstream-Status: Inappropriate [configuration]
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- bootstrap.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/bootstrap.sh b/bootstrap.sh
-index ca0b08d58..87f38dcf2 100755
---- a/bootstrap.sh
-+++ b/bootstrap.sh
-@@ -223,7 +223,7 @@ rm -f config.log
- if test "x$BJAM" = x; then
-   $ECHO -n "Building Boost.Build engine with toolset $TOOLSET... "
-   pwd=`pwd`
--  (cd "$my_dir/tools/build/src/engine" && ./build.sh "$TOOLSET") > bootstrap.log 2>&1
-+  (cd "$my_dir/tools/build/src/engine" && ./build.sh "$TOOLSET" --debug) > bootstrap.log 2>&1
-   if [ $? -ne 0 ]; then
-       echo
-       echo "Failed to build Boost.Build build engine" 
--- 
-2.17.1
-
diff --git a/meta/recipes-support/boost/files/0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch b/meta/recipes-support/boost/files/0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch
deleted file mode 100644 (file)
index 4c6ef2e..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From 2afd025997a57794ce24e07e914b461dfea6ba5f Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Mon, 26 Aug 2019 16:04:16 +0200
-Subject: [PATCH] build.sh: use -DNDEBUG also in debug builds
-
-Without it, there is a significant performance regression
-when running 'bjam install'.
-
-Upstream-Status: Inappropriate [configuration]
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- tools/build/src/engine/build.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/build/src/engine/build.sh b/tools/build/src/engine/build.sh
-index a1e4cd335..64e0a4c80 100755
---- a/tools/build/src/engine/build.sh
-+++ b/tools/build/src/engine/build.sh
-@@ -436,7 +436,7 @@ case $B2_OS in
-     ;;
- esac
--if check_debug_build "$@" ; then B2_CXXFLAGS="${B2_CXXFLAGS_DEBUG}"
-+if check_debug_build "$@" ; then B2_CXXFLAGS="${B2_CXXFLAGS_DEBUG} -DNDEBUG"
- else B2_CXXFLAGS="${B2_CXXFLAGS_RELEASE} -DNDEBUG"
- fi
- echo_run ${B2_CXX} ${CXXFLAGS} ${B2_CXXFLAGS} ${B2_SOURCES} -o b2