]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: ignore for musl/uclibc but only for target recipes
authorKhem Raj <raj.khem@gmail.com>
Tue, 28 Apr 2015 09:16:07 +0000 (02:16 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Jun 2015 15:34:38 +0000 (16:34 +0100)
we still need nativesdk  or native recipes for libc to come
from glibc, but only be ignored for target recipes types

Change-Id: Ibaf8114f2aef63f1eadf493b264e78cd928535a0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-core/glibc/glibc-collateral.inc
meta/recipes-core/glibc/glibc_2.21.bb

index f82db06cb90ba8fd680b93f32f80758484371d89..60655eba3c0dc634af9951d12ec2b2d8bdba190d 100644 (file)
@@ -17,3 +17,6 @@ do_compile[noexec] = "1"
 
 do_install[depends] += "virtual/${MLPREFIX}libc:do_populate_sysroot"
 
+COMPATIBLE_HOST_libc-musl_class-target = "null"
+COMPATIBLE_HOST_libc-uclibc_class-target = "null"
+
index 81b5a2bdbdda17f4a35a595dfecaa54d38ff627f..8197c29d2e4116e3f8b93ffa7381b39104e5bca6 100644 (file)
@@ -70,14 +70,11 @@ TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
 GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
 
 #
-# We will skip parsing glibc when system C library selection is not glibc
+# We will skip parsing glibc when target system C library selection is not glibc
 # this helps in easing out parsing for non-glibc system libraries
 #
-python __anonymous () {
-    if d.getVar('TCLIBC', True) != "glibc":
-        raise bb.parse.SkipPackage("incompatible with %s C library" %
-                                   d.getVar('TCLIBC', True))
-}
+COMPATIBLE_HOST_libc-musl_class-target = "null"
+COMPATIBLE_HOST_libc-uclibc_class-target = "null"
 
 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
                 --without-cvs --disable-profile \