]> code.ossystems Code Review - openembedded-core.git/commitdiff
apt: update use-host patch to support x86_64
authorSaul Wold <sgw@linux.intel.com>
Wed, 22 Dec 2010 07:04:24 +0000 (23:04 -0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 23 Dec 2010 14:20:50 +0000 (14:20 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/apt/apt-0.7.14/use-host.patch

index 894a69766108833173c01320a323498ece15ebd0..09698a6a40088479d9001fa7301f68e002a5ee8d 100644 (file)
@@ -3,11 +3,11 @@
  configure.in       |    2 +-
  2 files changed, 4 insertions(+), 2 deletions(-)
 
+Index: apt-0.7.14/buildlib/sizetable
+===================================================================
 --- apt-0.7.14.orig/buildlib/sizetable
 +++ apt-0.7.14/buildlib/sizetable
-@@ -9,16 +9,19 @@
- #
- # This is used primarily for the MD5 algorithm.
+@@ -11,6 +11,9 @@
  # The format is:-
  # CPU endian sizeof: char, int, short, long
  i386    little  1 4 2 4
  armeb   big     1 4 2 4
  arm     little  1 4 2 4
  alpha   little  1 4 2 8
- mipsel  little  1 4 2 4
- sparc   big     1 4 2 4
- sparc64 big     1 4 2 8
- m68k    big     1 4 2 4
+@@ -21,4 +24,5 @@ m68k    big     1 4 2 4
  powerpc big     1 4 2 4
  mips    big     1 4 2 4
  hppa    big     1 4 2 4
 -m32r  big     1 4 2 4
 \ No newline at end of file
 +m32r  big     1 4 2 4
++x86_64        little  1 4 2 8
+Index: apt-0.7.14/configure.in
+===================================================================
 --- apt-0.7.14.orig/configure.in
 +++ apt-0.7.14/configure.in
-@@ -86,11 +86,11 @@ AC_SUBST(BDBLIB)
- dnl Converts the ARCH to be something singular for this general CPU family
- dnl This is often the dpkg architecture string.
+@@ -88,7 +88,7 @@ dnl This is often the dpkg architecture 
  dnl First check against the full canonical canoncial-system-type in $target
  dnl and if that fails, just look for the cpu
  AC_MSG_CHECKING(debian architecture)
@@ -40,5 +38,3 @@
  if test "x$archset" = "x"; then
     AC_MSG_ERROR([failed: use --host= or output from dpkg-architecture])
  fi
- AC_MSG_RESULT($archset)
- AC_DEFINE_UNQUOTED(COMMON_ARCH,"$archset")