]> code.ossystems Code Review - openembedded-core.git/commitdiff
procps: pass CFLAGS to make
authorJoe Slater <jslater@windriver.com>
Thu, 15 Nov 2012 17:29:54 +0000 (17:29 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Nov 2012 15:12:07 +0000 (15:12 +0000)
EXTRA_OEMAKE in the recipe currently discards the
environment CFLAGS when setting CFLAGS passed to make.
We change that to include these options.

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/procps/procps_3.2.8.bb

index 7b011a01473898b6369933804ea4ea8451ee98c2..3f20beaf3056dac51ae5209729c5515ac1116054 100644 (file)
@@ -1,6 +1,6 @@
 require procps.inc
 
-PR = "r9"
+PR = "r10"
 
 SRC_URI += "file://procmodule.patch \
             file://psmodule.patch \
@@ -13,12 +13,12 @@ SRC_URI += "file://procmodule.patch \
 SRC_URI[md5sum] = "9532714b6846013ca9898984ba4cd7e0"
 SRC_URI[sha256sum] = "11ed68d8a4433b91cd833deb714a3aa849c02aea738c42e6b4557982419c1535"
 
-EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
+EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -I${STAGING_INCDIR}" \
                 CPPFLAGS=-I${STAGING_INCDIR} \
                 LDFLAGS="${LDFLAGS}" \
                 CURSES=-lncurses \
-                install='install -D' \
-                ldconfig=echo"
+                install="install -D" \
+                ldconfig=echo'
 
 do_install_append () {
        install -d ${D}${sysconfdir}