]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnutls: account for ARM_EABI
authorJoe Slater <jslater@windriver.com>
Wed, 25 Jan 2017 21:52:59 +0000 (13:52 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 31 Jan 2017 14:40:18 +0000 (14:40 +0000)
Do not reference unavailable system calls when
building for ARM_EABI.

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/gnutls/gnutls/arm_eabi.patch [new file with mode: 0644]
meta/recipes-support/gnutls/gnutls_3.5.7.bb

diff --git a/meta/recipes-support/gnutls/gnutls/arm_eabi.patch b/meta/recipes-support/gnutls/gnutls/arm_eabi.patch
new file mode 100644 (file)
index 0000000..34c8985
--- /dev/null
@@ -0,0 +1,19 @@
+Certain syscall's are not availabe for arm-eabi, so we eliminate
+reference to them.
+
+Upstream-Status: Pending
+
+Signed-off-by: Joe Slater <jslater@windriver.com>
+
+--- a/tests/seccomp.c
++++ b/tests/seccomp.c
+@@ -49,7 +49,9 @@ int disable_system_calls(void)
+       }
+       ADD_SYSCALL(nanosleep, 0);
++#if ! defined(__ARM_EABI__)
+       ADD_SYSCALL(time, 0);
++#endif
+       ADD_SYSCALL(getpid, 0);
+       ADD_SYSCALL(gettimeofday, 0);
+ #if defined(HAVE_CLOCK_GETTIME)
index cf77a20634198a80317e65f8cef14bb4563ca7fd..9508a8edcf5fa8c9ed2ae994f6f565247840a896 100644 (file)
@@ -4,6 +4,7 @@ SRC_URI += "file://correct_rpl_gettimeofday_signature.patch \
             file://0001-configure.ac-fix-sed-command.patch \
             file://use-pkg-config-to-locate-zlib.patch \
             file://0001-Do-not-add-cli-args.h-to-cli-args.stamp-Makefile-tar.patch \
+            file://arm_eabi.patch \
            "
 SRC_URI[md5sum] = "08ad2c539bc1d91283f610539deef34e"
 SRC_URI[sha256sum] = "60cbfc119e6268cfa38d712621daa473298a0c5b129c0842caec4c1ed4d7861a"