]> code.ossystems Code Review - openembedded-core.git/commitdiff
cpan.bbclass: Perform more mangling for perl path
authorTom Rini <tom_rini@mentor.com>
Mon, 18 Jul 2011 16:02:18 +0000 (09:02 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Jul 2011 09:46:31 +0000 (10:46 +0100)
On hosts where we may already be past the #! limit this is required
and this is safe on the target as well.  This is be7fe31 in oe.dev.
Related to this we now bump all PRs for recipes that inherit cpan.
Note that in oe.dev we mangle for perl but here we use the new
nativeperl script.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
meta/classes/cpan.bbclass
meta/recipes-devtools/perl/liburi-perl_1.58.bb
meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
meta/recipes-devtools/perl/libxml-perl_0.08.bb
meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb
meta/recipes-devtools/sgmlspl/sgmlspl-native_1.03ii.bb
meta/recipes-extended/perl/libconvert-asn1-perl_0.22.bb
meta/recipes-extended/perl/libtimedate-perl_1.20.bb
meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
meta/recipes-extended/perl/libxml-sax-perl_0.96.bb

index cbf428d3a2ad79ee15a3c79af70e137d7612287e..cb1c2f40c785a0a896791003b4982d8135b9fa1f 100644 (file)
@@ -35,6 +35,9 @@ cpan_do_compile () {
 
 cpan_do_install () {
        oe_runmake DESTDIR="${D}" install_vendor
+       for PERLSCRIPT in `grep -rIEl '#!${bindir}/perl-native.*/perl' ${D}`; do
+               sed -i -e 's|^#!${bindir}/perl-native.*/perl|#!/usr/bin/env nativeperl|' $PERLSCRIPT
+       done
 }
 
 EXPORT_FUNCTIONS do_configure do_compile do_install
index 76a1231388d79c206c57653aef14406697190ce4..ebb4911d4fe74b39ac51289b33cdf8ed46c8fc17 100644 (file)
@@ -4,7 +4,7 @@ and manipulate the various components that make up these strings."
 
 SECTION = "libs"
 LICENSE = "Artistic | GPLv1+"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
 
index 3f1a0ad500c2f0392e760ad63b11e55b036c3ed0..1d1593b1718f4716e70989e7157b0f9dbe415854 100644 (file)
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e
 
 DEPENDS += "expat expat-native"
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
 SRC_URI[md5sum] = "c66e9adba003d0667cc40115ccd837a5"
index 9c74cdb6b30f9b09cf69bb982dc5d4cf8bb1741f..fb637a8487d48ead8ba4be69537ccd8f1db4bed6 100644 (file)
@@ -5,7 +5,7 @@ XML::Grove and others."
 SUMMARY = "Collection of Perl modules for working with XML."
 SECTION = "libs"
 LICENSE = "Artistic | GPLv1+"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
 
index 89b65b29da287c378c5f8d2fbd57bfbf7a90da85..3a50d7f1d25a05e13803a6143ee10a2f7c64f49e 100644 (file)
@@ -2,7 +2,7 @@ SECTION = "libs"
 LICENSE = "Artistic"
 LIC_FILES_CHKSUM = "file://README;beginline=70;md5=94aa5d46682b411a53a5494cfb22640e"
 DEPENDS += "libxml-parser-perl"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
 
index 4e01f17b3e032450d6b38cd1bad1aa8b98fae716..28e0e9f391cd92e3102c8af064a2b1718dd2e02c 100644 (file)
@@ -4,7 +4,7 @@ HOMEPAGE = "http://search.cpan.org/src/DMEGG/SGMLSpm-1.03ii/DOC/HTML/SGMLSpm/sgm
 SECTION = "libs"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.cpan.org/authors/id/D/DM/DMEGG/SGMLSpm-${PV}.tar.gz \
            file://combined.patch"
index fc77b75090ca8fc5b2a00a438d9a644b089389fe..48e107c8faff374087a1607d4e51c126a1b4a470 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Convert::ASN1 - ASN.1 Encode/Decode library"
 SECTION = "libs"
 LICENSE = "Artistic|GPLv1+"
 LIC_FILES_CHKSUM = "file://README;beginline=10;endline=12;md5=a64b291b13ffddeef33b14f047ee8b26"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/Convert-ASN1-${PV}.tar.gz"
 
index 7298f37fd1652f86f3005b28cc9a9899936514a8..c925980d37ca6456d5670e490f0e2021bc3c47b2 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "libs"
 # You can redistribute it and/or modify it under the same terms as Perl itself.
 LICENSE = "Artistic|GPLv1+"
 LIC_FILES_CHKSUM = "file://README;beginline=21;md5=576b7cb41e5e821501a01ed66f0f9d9e"
-PR = "r2"
+PR = "r3"
 
 
 SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/TimeDate-${PV}.tar.gz"
index d96430e616615277143727ce3734f72f8418c3f2..f306ff19967d617e43344f74d89331ce1263ccca 100644 (file)
@@ -5,7 +5,7 @@ DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-ba
 
 SECTION = "libs"
 LICENSE = "Artistic|GPLv1+"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=3b2b564dae8b9af9e8896e85c07dcbe5"
 
index 13956cb16e58063692193e7b81f9def282ad26c4..97d2025a378f72227419709f7fa8306648ca0f80 100644 (file)
@@ -11,7 +11,7 @@ SECTION = "libs"
 LICENSE = "Artistic|GPLv1+"
 DEPENDS += "libxml-namespacesupport-perl-native"
 RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"