]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm-postinst: remove un-needed RDEPENDS on base-files
authorSaul Wold <sgw@linux.intel.com>
Thu, 16 May 2013 18:03:05 +0000 (21:03 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 May 2013 06:36:37 +0000 (09:36 +0300)
This was transferred un-intentionally when we split the rpm code,
the base-files then layed down additional files (specificaly /etc/mtab)
in the initramfs image and caused problems for the installer code.

Removing the RDEPENDS will fix the image generation issue and thus
the installer, so we will need to revert a previous patch that attempted
to fix the earlier issue #4229.

[YOCTO #4504]
[YOCTO #4229]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm-postinsts.bb

index 3d2d05d19ac29e420a5bf0a5b15b7ab8bf05e81e..3c0f520d2875e631b01f2a3b48418cb03a19de6a 100644 (file)
@@ -3,8 +3,6 @@ SECTION = "core"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780"
 
-RDEPENDS_${PN} = "base-files"
-
 inherit allarch
 #
 # Allow distributions to alter when [postponed] package install scripts are run