]> code.ossystems Code Review - openembedded-core.git/commitdiff
gobject-introspection: improve reproducibility
authorJuro Bystricky <juro.bystricky@intel.com>
Tue, 24 Oct 2017 21:04:09 +0000 (14:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Nov 2017 22:23:45 +0000 (22:23 +0000)
Remove cross-compiler wrappers from the package, these contain numerous
build host references.
The wrappers are only needed for cross-compiling.

[YOCTO #11705]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-gnome/gobject-introspection/gobject-introspection_1.52.1.bb

index 605f02eb0e893cf34801cf303c42bc793bf3a1e8..3fe71a3896cbf2f3be8b7f87e5803d8d54f28a12 100644 (file)
@@ -177,3 +177,12 @@ gi_ldsoconf_sysroot_preprocess () {
        echo "echo ${libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
        chmod 755 $dest
 }
+
+# Remove wrapper files from the package, only used for cross-compiling
+PACKAGE_PREPROCESS_FUNCS += "gi_package_preprocess"
+gi_package_preprocess() {
+       rm -f ${PKGD}${bindir}/g-ir-scanner-qemuwrapper
+       rm -f ${PKGD}${bindir}/g-ir-scanner-wrapper
+       rm -f ${PKGD}${bindir}/g-ir-compiler-wrapper
+       rm -f ${PKGD}${bindir}/g-ir-scanner-lddwrapper
+}