]> code.ossystems Code Review - openembedded-core.git/commitdiff
lz4: remove ptest changes
authorRoss Burton <ross.burton@intel.com>
Wed, 17 Jan 2018 11:14:00 +0000 (12:14 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 25 Jan 2018 11:36:06 +0000 (11:36 +0000)
This recipe installs the test suite by copying the entire build tree into
/usr/share/ptest, which is both wasteful and breaks packaging as lz4-ptest then
gets renamed by debian.bbclass to liblz4.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-support/lz4/lz4_1.7.4.bb

index 9e86985d6991e3b50e695cc6a6228b54de847a06..86a1ab9ab950fa21126a909b430b8e9700bf8ac0 100644 (file)
@@ -17,19 +17,11 @@ SRC_URI = "git://github.com/lz4/lz4.git \
 UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
 
 S = "${WORKDIR}/git"
-inherit ptest
 
-EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}" 
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
 
 do_install() {
        oe_runmake install
 }
 
-do_install_ptest () {
-       install -d ${D}${PTEST_PATH}/testsuite
-       cp -rf ${S}/* ${D}${PTEST_PATH}/testsuite
-}
-
-RDEPENDS_${PN}-ptest += "make python3"
-
 BBCLASSEXTEND = "native nativesdk"