]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp_5.0.2: Set CC_FOR_BUILD to BUILD_CC
authorTom Zanussi <tom.zanussi@intel.com>
Wed, 2 Nov 2011 03:25:58 +0000 (22:25 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Nov 2011 21:44:22 +0000 (21:44 +0000)
CC_FOR_BUILD was compiling the test programs using the target's
compile options and executing those on the host, causing errors such
as:

/bin/sh: line 1: 15032 Illegal instruction     ./gen-bases table 64 0 > mpn/mp_bases.c
/bin/sh: line 1: 15033 Illegal instruction     ./gen-bases header 64 0 > mp_bases.h

Export CC_FOR_BUILD using BUILD_CC to fix the problem.

Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
meta/recipes-support/gmp/gmp_5.0.2.bb

index 03fef453e9b30a657a4d9c58d374884572686735..16bdcbc2b71cfe39aa8a65e19eb583af202dd494 100644 (file)
@@ -2,11 +2,12 @@ require gmp.inc
 LICENSE="LGPLv3&GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                    file://version.c;endline=18;md5=d8c56b52b9092346b9f93b4da65ef790"
-PR = "r0"
+PR = "r1"
 
 SRC_URI_append += "file://sh4-asmfix.patch \
                    file://use-includedir.patch "
 
+export CC_FOR_BUILD = "${BUILD_CC}"
 
 SRC_URI[md5sum] = "0bbaedc82fb30315b06b1588b9077cd3"
 SRC_URI[sha256sum] = "dbc2db76fdd4e99f85d5e35aa378ed62c283e0d586b91bd8703aff75a7804c28"