]> code.ossystems Code Review - openembedded-core.git/commitdiff
file: add wrapper to file-native
authorSaul Wold <sgw@linux.intel.com>
Sat, 26 Feb 2011 00:18:50 +0000 (16:18 -0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 1 Mar 2011 11:46:47 +0000 (11:46 +0000)
file-native needs a wrapper to pass the correct path to the magic.mgc file
This was found to be the case when sstate-cache is used because file hardcodes
the path to the magic.mgc file.

[BUGID #775]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/file/file_5.04.bb

index b7451372f59f1229e47100eed02ae72c09b3766b..1f9c78eb7b61314bcdaee9455d8d524ba31ac683 100644 (file)
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03
 
 DEPENDS = "zlib file-native"
 DEPENDS_virtclass-native = "zlib-native"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
            file://stringb-compat.patch \
@@ -30,4 +30,10 @@ do_configure_prepend() {
 
 FILES_${PN} += "${datadir}/misc/*.mgc"
 
+do_install_append_virtclass-native() {
+       create_cmdline_wrapper ${D}/${bindir}/file \
+               --magic-file ${datadir}/misc/magic.mgc
+}
+
+
 BBCLASSEXTEND = "native"