]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-rt: use correct branch names and new git SRC_REV format
authorDarren Hart <dvhart@linux.intel.com>
Tue, 19 Apr 2011 23:54:38 +0000 (16:54 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Apr 2011 01:17:49 +0000 (02:17 +0100)
The RT kernel recipe was not updated to reflect the new git SRC_REV format nor
to take advantage of the recent updates made to the underlying infrastructure.
These fixes bring it up to date with the other linux-yocto* recipes and fix
various build issues people were seeing.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Cc: Bruce Ashfield <bruce.ashfield@windriver.com>
meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb

index 547f8feac37664e022657950dc41973325001b02..cba132176adb717421a9d5aa93bf7fc1c9b4b697 100644 (file)
@@ -8,7 +8,10 @@ LINUX_VERSION ?= "2.6.34"
 LINUX_KERNEL_TYPE = "preempt_rt"
 LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
 
-PR = "r0"
+KMETA = wrs_meta
+KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
+
+PR = "r1"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 SRCREV_FORMAT = "meta_machine"
 
@@ -18,16 +21,11 @@ COMPATIBLE_MACHINE = "(qemux86-64|atom-pc)"
 python __anonymous () {
     import bb, re, string
 
-    rev = bb.data.getVar("SRCREV_machine", d, 1)
-    if rev == "standard":
-        bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d)
-
     kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
     bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
 }
 
-SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
-           git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
+SRC_URI = "git://git.yoctoproject.org/linux-2.6-windriver.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
 
 # Functionality flags
 KERNEL_REVISION_CHECKING ?= "t"