]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpam: Security Advisory - CVE-2014-2583
authorYue Tao <Yue.Tao@windriver.com>
Tue, 17 Jun 2014 08:23:59 +0000 (04:23 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Jun 2014 09:23:45 +0000 (10:23 +0100)
v2 changes:
* update format for commit log
* add Upstream-Status for patch

Multiple directory traversal vulnerabilities in pam_timestamp.c in the
pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to
create aribitrary files or possibly bypass authentication via a .. (dot
dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY
value to the check_tty funtion, which is used by the
format_timestamp_name function.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-2583

Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/pam/libpam/pam_timestamp-fix-potential-directory-traversal-issu.patch [new file with mode: 0644]
meta/recipes-extended/pam/libpam_1.1.6.bb

diff --git a/meta/recipes-extended/pam/libpam/pam_timestamp-fix-potential-directory-traversal-issu.patch b/meta/recipes-extended/pam/libpam/pam_timestamp-fix-potential-directory-traversal-issu.patch
new file mode 100644 (file)
index 0000000..06cca13
--- /dev/null
@@ -0,0 +1,63 @@
+From 9dcead87e6d7f66d34e7a56d11a30daca367dffb Mon Sep 17 00:00:00 2001
+From: "Dmitry V. Levin" <ldv@altlinux.org>
+Date: Wed, 26 Mar 2014 22:17:23 +0000
+Subject: [PATCH] pam_timestamp: fix potential directory traversal issue
+ (ticket #27)
+
+commit 9dcead87e6d7f66d34e7a56d11a30daca367dffb upstream
+
+pam_timestamp uses values of PAM_RUSER and PAM_TTY as components of
+the timestamp pathname it creates, so extra care should be taken to
+avoid potential directory traversal issues.
+
+* modules/pam_timestamp/pam_timestamp.c (check_tty): Treat
+"." and ".." tty values as invalid.
+(get_ruser): Treat "." and ".." ruser values, as well as any ruser
+value containing '/', as invalid.
+
+Fixes CVE-2014-2583.
+
+Reported-by: Sebastian Krahmer <krahmer@suse.de>
+
+Upstream-Status: Backport
+
+Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+---
+ modules/pam_timestamp/pam_timestamp.c |   13 ++++++++++++-
+ 1 files changed, 12 insertions(+), 1 deletions(-)
+
+diff --git a/modules/pam_timestamp/pam_timestamp.c b/modules/pam_timestamp/pam_timestamp.c
+index 5193733..b3f08b1 100644
+--- a/modules/pam_timestamp/pam_timestamp.c
++++ b/modules/pam_timestamp/pam_timestamp.c
+@@ -158,7 +158,7 @@ check_tty(const char *tty)
+               tty = strrchr(tty, '/') + 1;
+       }
+       /* Make sure the tty wasn't actually a directory (no basename). */
+-      if (strlen(tty) == 0) {
++      if (!strlen(tty) || !strcmp(tty, ".") || !strcmp(tty, "..")) {
+               return NULL;
+       }
+       return tty;
+@@ -243,6 +243,17 @@ get_ruser(pam_handle_t *pamh, char *ruserbuf, size_t ruserbuflen)
+               if (pwd != NULL) {
+                       ruser = pwd->pw_name;
+               }
++      } else {
++              /*
++               * This ruser is used by format_timestamp_name as a component
++               * of constructed timestamp pathname, so ".", "..", and '/'
++               * are disallowed to avoid potential path traversal issues.
++               */
++              if (!strcmp(ruser, ".") ||
++                  !strcmp(ruser, "..") ||
++                  strchr(ruser, '/')) {
++                      ruser = NULL;
++              }
+       }
+       if (ruser == NULL || strlen(ruser) >= ruserbuflen) {
+               *ruserbuf = '\0';
+-- 
+1.7.5.4
+
index 7e55adfb04844d5f89f457f938977a39e6f7b297..3190aaf0d1823ff04d54bf29df8a436399677c6b 100644 (file)
@@ -25,6 +25,7 @@ SRC_URI = "http://linux-pam.org/library/Linux-PAM-${PV}.tar.bz2 \
            file://libpam-fix-for-CVE-2010-4708.patch \
            file://pam-security-abstract-securetty-handling.patch \
            file://pam-unix-nullok-secure.patch \
+           file://pam_timestamp-fix-potential-directory-traversal-issu.patch \
           "
 SRC_URI[md5sum] = "7b73e58b7ce79ffa321d408de06db2c4"
 SRC_URI[sha256sum] = "bab887d6280f47fc3963df3b95735a27a16f0f663636163ddf3acab5f1149fc2"