]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: improve reproducibility
authorJuro Bystricky <juro.bystricky@intel.com>
Tue, 15 Aug 2017 22:01:30 +0000 (15:01 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Aug 2017 08:18:47 +0000 (09:18 +0100)
Remove references to the host build system from generated/packaged
header file gmp.h. The file ends up in two different packages (libgmp-dev,
libgmp-dbg). Rather then modifying the file twice in two different
destinations after the installation, we modify the file gmp.h only once,
but before the installation.

[YOCTO #11922]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gmp/gmp_6.1.2.bb

index 5e650755858ea0f2e364728e5d78de7fa8da703b..b008710d0f0fcc2c6930d9cd1d474385c911a715 100644 (file)
@@ -25,8 +25,11 @@ EXTRA_OECONF_mipsarchr6_append = " --disable-assembly"
 PACKAGES =+ "libgmpxx"
 FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}"
 
-do_install_append_class-target() {
-        sed -i "s|--sysroot=${STAGING_DIR_HOST}||g" ${D}${includedir}/gmp.h
+do_install_prepend_class-target() {
+        sed -i \
+        -e "s|--sysroot=${STAGING_DIR_HOST}||g" \
+        -e "s|${DEBUG_PREFIX_MAP}||g" \
+         ${B}/gmp.h
 }
 
 SSTATE_SCAN_FILES += "gmp.h"