]> code.ossystems Code Review - openembedded-core.git/commitdiff
ell: upgrade 0.33 -> 0.35
authorAlexander Kanavin <alex.kanavin@gmail.com>
Sat, 26 Dec 2020 09:27:19 +0000 (10:27 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 31 Dec 2020 11:56:38 +0000 (11:56 +0000)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/ell/ell/0001-ell-add-missing-include-in-dhcp-server.patch [new file with mode: 0644]
meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch [new file with mode: 0644]
meta/recipes-core/ell/ell_0.35.bb [moved from meta/recipes-core/ell/ell_0.33.bb with 73% similarity]

diff --git a/meta/recipes-core/ell/ell/0001-ell-add-missing-include-in-dhcp-server.patch b/meta/recipes-core/ell/ell/0001-ell-add-missing-include-in-dhcp-server.patch
new file mode 100644 (file)
index 0000000..2460d26
--- /dev/null
@@ -0,0 +1,23 @@
+From dd350f4e2258b5a638bc8fb26a6193147902d292 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C3=89rico=20Nogueira?= <ericonr@disroot.org>
+Date: Mon, 30 Nov 2020 18:40:33 -0300
+Subject: [PATCH] ell: add missing include in dhcp-server.
+
+Upstream-Status: Backport
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ ell/dhcp-server.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ell/dhcp-server.c b/ell/dhcp-server.c
+index c983ed4..144e83e 100644
+--- a/ell/dhcp-server.c
++++ b/ell/dhcp-server.c
+@@ -24,6 +24,7 @@
+ #include <config.h>
+ #endif
++#include <linux/types.h>
+ #include <net/ethernet.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
diff --git a/meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch b/meta/recipes-core/ell/ell/0001-pem.c-do-not-use-rawmemchr.patch
new file mode 100644 (file)
index 0000000..f0ce6f1
--- /dev/null
@@ -0,0 +1,27 @@
+From 277e1eca67fcc23cb31be7b826d83a19d9b89bd2 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 22 Dec 2020 10:30:54 +0000
+Subject: [PATCH] pem.c: do not use rawmemchr()
+
+This is a glibc-only function, and causes build failures with
+alternative libc implementations such as musl.
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ ell/pem.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ell/pem.c b/ell/pem.c
+index 790f2c2..237ae02 100644
+--- a/ell/pem.c
++++ b/ell/pem.c
+@@ -224,7 +224,7 @@ static uint8_t *pem_load_buffer(const void *buf, size_t buf_len,
+               /* Check that each header line has a key and a colon */
+               while (start < end) {
+-                      const char *lf = rawmemchr(start, '\n');
++                      const char *lf = memchr(start, '\n', end - start);
+                       const char *colon = memchr(start, ':', lf - start);
+                       if (!colon)
similarity index 73%
rename from meta/recipes-core/ell/ell_0.33.bb
rename to meta/recipes-core/ell/ell_0.35.bb
index 2fa05104fb4d2b0569ed569dc8fece1a7c8dd611..ccc54b5ff7f1e8442aa47bd57f3581618ad69f9e 100644 (file)
@@ -13,8 +13,11 @@ DEPENDS = "dbus"
 
 inherit autotools pkgconfig
 
-SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
-SRC_URI[sha256sum] = "d9e40e641164150394b74b719b9726fc734f24b2cde679cf5f3be6915c34eded"
+SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
+           file://0001-ell-add-missing-include-in-dhcp-server.patch \
+           file://0001-pem.c-do-not-use-rawmemchr.patch \
+           "
+SRC_URI[sha256sum] = "2bfe9da7781f65f1cb1595a5a068a3ae74d4b68b74f287c6f0c892cfe623913f"
 
 do_configure_prepend () {
     mkdir -p ${S}/build-aux