]> code.ossystems Code Review - openembedded-core.git/commitdiff
file: add wrapper to nativesdk-file
authorHongxu Jia <hongxu.jia@windriver.com>
Sat, 11 Oct 2014 08:59:22 +0000 (16:59 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 18 Oct 2014 14:12:55 +0000 (16:12 +0200)
"file" command in exported SDK doesn't work:
...
$ file sysroots/
file: could not find any valid magic files!
...

In oe-core commit 68d548cbae729eaea8ce1403dc95ff63c4a7375c,
it added wrapper to file-native. Do the same thing for
nativesdk-file.

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/file/file_5.18.bb

index f2f8d032e2e04e1ce1e0cea65d155f27fdc1df5f..9068b9314a31d5fc08ff79cdea2e86282f382c53 100644 (file)
@@ -27,4 +27,9 @@ do_install_append_class-native() {
                --magic-file ${datadir}/misc/magic.mgc
 }
 
+do_install_append_class-nativesdk() {
+       create_cmdline_wrapper ${D}/${bindir}/file \
+               --magic-file ${datadir}/misc/magic.mgc
+}
+
 BBCLASSEXTEND = "native nativesdk"