]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: fix machine compatibility
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 13 Dec 2010 06:23:56 +0000 (01:23 -0500)
committerBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 13 Dec 2010 06:23:56 +0000 (01:23 -0500)
During the last phase of the recipe factoring, the board compatibility
lists ended up in the wrong place, which meant we had an incomplete
list of boards, and the same set of boards for both kernels (stable
and devel).

To fix this, I've yanked the compatibility to the recipes themselves and
updated the emenlow to have a -stable bbappend.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta-emenlow/recipes/linux/linux-yocto-stable_git.bbappend [moved from meta-emenlow/recipes/linux/linux-yocto_git.bbappend with 100% similarity]
meta/recipes-kernel/linux/linux-yocto-stable_git.bb
meta/recipes-kernel/linux/linux-yocto.inc
meta/recipes-kernel/linux/linux-yocto_git.bb

index 8ecd86fa9f7b3458b15a2dd94aa8375fa51326c5..dd4d176ac5ed98d56f6ce9c60fa23c5e45caa940 100644 (file)
@@ -17,6 +17,8 @@ PR = "r0"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 SRCREV_FORMAT = "meta_machine"
 
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro|mpc8315e-rdb|beagleboard)"
+
 # this performs a fixup on the SRCREV for new/undefined BSPs
 python __anonymous () {
     import bb, re
index 095b3375fac6f5cd7e5898d1e7071fc5fad6f320..2a77f4a9c4273f7eedb8f81c48aae97aa5eb6817 100644 (file)
@@ -7,8 +7,6 @@ LICENSE = "GPL"
 # and it can be specific to the machine or shared
 KMACHINE = "UNDEFINED"
 
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|atom-pc|routerstationpro)"
-
 # Set this to 'preempt_rt' in the local.conf if you want a real time kernel
 LINUX_KERNEL_TYPE ?= standard
 
index 1e3df478eb693b1e979caf7732538bac178f4dd9..f40fe38fcd3a983af604b06740cf59428ddfca05 100644 (file)
@@ -20,6 +20,7 @@ SRCREV_FORMAT = "meta_machine"
 SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
            git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta"
 
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
 
 # Functionality flags
 KERNEL_REVISION_CHECKING ?= "t"