]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-standalone-sdk-target: add libssp
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Fri, 7 Apr 2017 02:38:13 +0000 (14:38 +1200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 Aug 2017 14:11:36 +0000 (15:11 +0100)
If you want to be able to use -fstack-protector then you need the
runtime support - you can either write this yourself or use libssp
supplied with GCC. If you're using GCC then it seems likely that you'd
just be using libssp, so include in the SDK by default; however use
RRECOMMENDS just in case it's been disabled or you aren't using GCC.

(From OE-Core rev: 6c990655e35bb3a14d59555662ec5802c9980028)

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb

index 274e11a8b0754b4063affd434cb85b935110bfb4..43fc599c73873c8618387e721b1799492284aeec 100644 (file)
@@ -12,3 +12,8 @@ RDEPENDS_${PN} = "\
     libstdc++-dev \
     ${LIBC_DEPENDENCIES} \
     "
+
+RRECOMMENDS_${PN} = "\
+    libssp \
+    libssp-dev \
+    "