]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: remove invalid sed command
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 10 Jul 2015 07:14:50 +0000 (00:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jul 2015 21:53:20 +0000 (22:53 +0100)
The sed command was used for editting to code added by
linker-flags.patch, but the patch had been gone in 2013, and verified
that there is no -lX11 in Makefile.target, so remove the
sed command.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemu.inc

index ca94fb223d9a0e210d00a914e1838cf79a9aed66..d794af9462fdbb79217df770eee71440945c5314 100644 (file)
@@ -37,16 +37,6 @@ do_configure_prepend_class-native() {
        if [ ! -z "$BHOST_PKGCONFIG_PATH" ]; then
                export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:$BHOST_PKGCONFIG_PATH
        fi
-
-       # Undo the -lX11 added by linker-flags.patch, don't assume that host has libX11 installed
-       sed -i 's/-lX11//g' ${S}/Makefile.target
-}
-
-do_configure_prepend_class-nativesdk() {
-       if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "" ] ; then
-               # Undo the -lX11 added by linker-flags.patch
-               sed -i 's/-lX11//g' ${S}/Makefile.target
-       fi
 }
 
 KVMENABLE = "--enable-kvm"