]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool-cross: Add libtool & libtoolize to SSTATE_SCAN_FILES
authorSaul Wold <sgw@linux.intel.com>
Thu, 15 Dec 2011 00:06:22 +0000 (16:06 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 15 Dec 2011 14:34:44 +0000 (14:34 +0000)
This fixes problems where hardcoded paths in the file were incorrect
during sstate reusage of the task output.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb

index 5003c9bd2c50c48c00a628dd476b49e7658b94c9..97794a6210cc567d404d25969b5f318e76441af3 100644 (file)
@@ -1,6 +1,6 @@
 require libtool-${PV}.inc
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PACKAGES = ""
 SRC_URI += "file://prefix.patch"
 SRC_URI += "file://fixinstall.patch"
@@ -34,3 +34,5 @@ libtoolcross_sysroot_preprocess () {
        sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
        sysroot_stage_dir ${D}${target_datadir} ${SYSROOT_DESTDIR}${target_datadir}
 }
+
+SSTATE_SCAN_FILES += "libtoolize *-libtool"