]> code.ossystems Code Review - openembedded-core.git/commitdiff
v86d: Make cross compilation working on more architectures
authorSerhey Popovych <serhe.popovych@gmail.com>
Wed, 31 Oct 2018 14:55:47 +0000 (16:55 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Nov 2018 12:14:05 +0000 (12:14 +0000)
Since commit 709c603dec19 ("v86d: Accept aarch64 as build host") we
support cross compilation on aarch64 host in addition to x86 host.
However building on hosts different than two above will fail.

Make cross compilation support more generic by checking for TARGET_ARCH
in v86d configure script with fallback to `uname -m` when not present in
environment and pass TARGET_ARCH explicitly in do_configure().

Cross build for x86 tested on IBM Power 8 machine with RHEL7. Should
work on aarch64 and rest too.

Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/v86d/v86d/Support-for-cross-compilation.patch [new file with mode: 0644]
meta/recipes-bsp/v86d/v86d/aarch64-host.patch [deleted file]
meta/recipes-bsp/v86d/v86d_0.1.10.bb

diff --git a/meta/recipes-bsp/v86d/v86d/Support-for-cross-compilation.patch b/meta/recipes-bsp/v86d/v86d/Support-for-cross-compilation.patch
new file mode 100644 (file)
index 0000000..15f70a5
--- /dev/null
@@ -0,0 +1,34 @@
+From 8eda59654fd31416164c78f6068715b01767ed4e Mon Sep 17 00:00:00 2001
+From: Serhey Popovych <serhe.popovych@gmail.com>
+Date: Wed, 31 Oct 2018 07:31:47 -0400
+Subject: v86d: Support for cross compilation
+
+It is common to build on one system for another (e.g. on IBM Power
+machine for Intel x86) where HOST_ARCH (uname -m) != TARGET_ARCH.
+
+Take TARGET_ARCH from environment if it is given, otherwise fall back
+to `uname -m`.
+
+Upstream-Status: Pending
+Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
+---
+ configure | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index cbbd6b3..046aa99 100755
+--- a/configure
++++ b/configure
+@@ -23,7 +23,8 @@ copt_x86emu_type="bool"
+ copt_x86emu_def=auto
+ copt_x86emu_test()
+ {
+-      local m=`uname -m`
++      local m="${TARGET_ARCH:-$(uname -m)}"
++
+       if [ "$m" = "i686" -o "$m" = "i586" -o "$m" = "i486" -o "$m" = "i386" ]; then
+               echo "n";
+       elif [ "$m" = "x86_64" ]; then
+-- 
+1.8.3.1
+
diff --git a/meta/recipes-bsp/v86d/v86d/aarch64-host.patch b/meta/recipes-bsp/v86d/v86d/aarch64-host.patch
deleted file mode 100644 (file)
index 701fed7..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Accept aarch64 as valid build host
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: v86d-0.1.10/configure
-===================================================================
---- v86d-0.1.10.orig/configure
-+++ v86d-0.1.10/configure
-@@ -26,7 +26,7 @@ copt_x86emu_test()
-       local m=`uname -m`
-       if [ "$m" = "i686" -o "$m" = "i586" -o "$m" = "i486" -o "$m" = "i386" ]; then
-               echo "n";
--      elif [ "$m" = "x86_64" ]; then
-+      elif [ "$m" = "x86_64" -o "$m" = "aarch64" ]; then
-               echo "y";
-       else
-               echo "It looks like your architecture '$m' isn't supported by this version of v86d." >&2
index f97b80d08f698172ab7851c30c6ddbc7301340d7..84e27d2007027b265d46ce5c874df54ddc9824a1 100644 (file)
@@ -12,7 +12,7 @@ PR = "r2"
 SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \
            file://Update-x86emu-from-X.org.patch \
            file://ar-from-env.patch \
-           file://aarch64-host.patch \
+           file://Support-for-cross-compilation.patch \
 "
 
 SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2"
@@ -22,7 +22,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
 
 do_configure () {
-       ./configure --with-x86emu
+       TARGET_ARCH="${TARGET_ARCH}" ./configure --with-x86emu
 }
 
 do_compile () {