]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: correct bad path on package preprocess
authorChristophe PRIOUZEAU <christophe.priouzeau@st.com>
Thu, 22 Nov 2018 12:13:11 +0000 (12:13 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 8 Jan 2019 20:12:10 +0000 (20:12 +0000)
In case of SDK generation, /usr/bin/ path are not correct
and must be replaced by ${bindir}.

(From OE-Core rev: 0fa7d99444763192914e798d8bc9dba1d9cdae42)

Signed-off-by: Christophe Priouzeau <christophe.priouzeau@st.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb

index 432594070103c0ed833a0cb40641e7373ac4329e..42f9bcfdcc3e748af2987a0eb303873292201834 100644 (file)
@@ -354,8 +354,8 @@ openssl_package_preprocess () {
         for file in `find ${PKGD} -name *.h -o -name *.pc -o -name *.so`; do
                 rm $file
         done
-        rm ${PKGD}/usr/bin/openssl
-        rm ${PKGD}/usr/bin/c_rehash
-        rmdir ${PKGD}/usr/bin
+        rm ${PKGD}${bindir}/openssl
+        rm ${PKGD}${bindir}/c_rehash
+        rmdir ${PKGD}${bindir}
 
 }