]> code.ossystems Code Review - openembedded-core.git/commitdiff
Revert "distcc: move ASNEEDED over-ride into the distcc recipe"
authorRoss Burton <ross.burton@intel.com>
Sun, 13 May 2018 20:06:42 +0000 (21:06 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 29 May 2018 10:25:03 +0000 (11:25 +0100)
This reverts commit 3fbec7916c401b987184f4b25dda39cf355b2a60.

meta/conf/distro/include/as-needed.inc
meta/recipes-devtools/distcc/distcc_3.2.bb

index 9c235649b7be6c908e3d3042cf728e7e56678eb2..f2e7e7b588f31004f86ab5eece39f3a3e7b8d015 100644 (file)
@@ -1,6 +1,7 @@
 
 ASNEEDED = "-Wl,--as-needed"
 
+ASNEEDED_pn-distcc = ""
 ASNEEDED_pn-openobex = ""
 
 TARGET_LDFLAGS += "${ASNEEDED}"
index ee077495d5f10e0ad92e33978563348e4dfc9586..66046480b90f9a562f52c479e3b19da7f3ccf42f 100644 (file)
@@ -7,6 +7,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 DEPENDS = "avahi binutils"
 
+PACKAGECONFIG ??= "popt"
+PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
+# use system popt by default
+PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
+
+RRECOMMENDS_${PN} = "avahi-daemon"
+
 SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
            file://separatebuilddir.patch \
            file://0001-zeroconf-Include-fcntl.h.patch \
@@ -14,26 +21,12 @@ SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
            file://distccmon-gnome.desktop \
            file://distcc \
            file://distcc.service"
-
 SRCREV = "d8b18df3e9dcbe4f092bed565835d3975e99432c"
-
 S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig update-rc.d useradd systemd
 
-PACKAGECONFIG ??= "popt"
-
-PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
-# use system popt by default
-PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
-
-EXTRA_OECONF += " \
-    --disable-pump-mode \
-    --disable-Werror \
-    PYTHON='' \
-"
-
-ASNEEDED = ""
+EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
 
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM_${PN} = "--system \
@@ -59,22 +52,18 @@ do_install() {
     sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
     ${DESKTOPINSTALL}
 }
-
 DESKTOPINSTALL = ""
 DESKTOPINSTALL_libc-glibc () {
     install -d ${D}${datadir}/distcc/
     install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
 }
-
 PACKAGES += "distcc-distmon-gnome"
 
 FILES_${PN} = " ${sysconfdir} \
                ${bindir}/distcc \
-               ${bindir}/lsdistcc \
+    ${bindir}/lsdistcc \
                ${bindir}/distccd \
                ${bindir}/distccmon-text \
                ${systemd_unitdir}/system/distcc.service"
 FILES_distcc-distmon-gnome = "  ${bindir}/distccmon-gnome \
                                ${datadir}/distcc"
-
-RRECOMMENDS_${PN} = "avahi-daemon"