]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add a patch to oparchive so that the program exits with non-zero exit code on
authorRobert Bradford <rob@openedhand.com>
Tue, 27 Feb 2007 17:56:16 +0000 (17:56 +0000)
committerRobert Bradford <rob@openedhand.com>
Tue, 27 Feb 2007 17:56:16 +0000 (17:56 +0000)
error.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1295 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch [new file with mode: 0644]
meta/packages/oprofile/oprofile_cvs.bb

diff --git a/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch b/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch
new file mode 100644 (file)
index 0000000..ab4d7f4
--- /dev/null
@@ -0,0 +1,11 @@
+Index: oprofile/pp/oparchive.cpp
+===================================================================
+--- oprofile.orig/pp/oparchive.cpp     2007-02-27 18:15:52.000000000 +0000
++++ oprofile/pp/oparchive.cpp  2007-02-27 18:16:08.000000000 +0000
+@@ -164,5 +164,5 @@
+ int main(int argc, char const * argv[])
+ {
+-      run_pp_tool(argc, argv, oparchive);
++      return run_pp_tool(argc, argv, oparchive);
+ }
index 034ea51ff0698ab1eae3f91f4b9b5c6626dd424b..4c45709818133c2f16b2c45849aab88f18b593bd 100644 (file)
@@ -12,6 +12,7 @@ SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=
           file://oparchive-list-files.patch;patch=1 \
           file://opreport-xml-output-fixes.patch;patch=1 \
            file://xml_callgraph.patch;patch=1 \
+           file://oparchive-exit-code-on-error.patch;patch=1 \
           file://acinclude.m4"
 S = "${WORKDIR}/oprofile"