]> code.ossystems Code Review - openembedded-core.git/commitdiff
eglibc: fix build of eglibc-initial for make 3.82
authorJoshua Lock <josh@linux.intel.com>
Tue, 9 Nov 2010 12:14:28 +0000 (12:14 +0000)
committerJoshua Lock <josh@linux.intel.com>
Tue, 9 Nov 2010 14:09:54 +0000 (14:09 +0000)
Make 3.82, as shipped with Fedora 14, fixes some holes in the parser which in
turn breaks behaviour of some Makefiles. Most notably eglibc's.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc_2.12.bb

diff --git a/meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff b/meta/recipes-core/eglibc/eglibc-2.12/fix-for-make-3.82.diff
new file mode 100644 (file)
index 0000000..934d31a
--- /dev/null
@@ -0,0 +1,25 @@
+Make 3.82, as shipped with Fedora 14, fixes some holes in the parser which in
+turn breaks behaviour of some Makefiles. Most notably eglibc's.
+
+http://www.mail-archive.com/bug-make@gnu.org/msg06220.html
+
+Fix back-ported from glibc/eglibc revision control.
+
+JL 13/10/10
+
+Index: libc/manual/Makefile
+===================================================================
+--- libc.orig/manual/Makefile
++++ libc/manual/Makefile
+@@ -243,7 +243,10 @@ ifdef objpfx
+ .PHONY: stubs
+ stubs: $(objpfx)stubs
+ endif
+-$(objpfx)stubs ../po/manual.pot $(objpfx)stamp%:
++$(objpfx)stubs ../po/manual.pot:
++      $(make-target-directory)
++      touch $@
++$(objpfx)stamp%:
+       $(make-target-directory)
+       touch $@
index 752c1d8ceefd893ef2d608a872cebceaf0426af1..9db1436ae6aeae499848177ee7c690494a10bd63 100644 (file)
@@ -2,7 +2,7 @@ require eglibc.inc
 
 DEPENDS += "gperf-native"
 FILESPATHPKG =. "eglibc-svn:"
-PR = "r9"
+PR = "r10"
 
 EGLIBC_BRANCH="eglibc-2_12"
 SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
@@ -11,7 +11,8 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http
            file://shorten-build-commands.patch \
            file://mips-rld-map-check.patch \
            file://etc/ld.so.conf \
-           file://generate-supported.mk"
+           file://generate-supported.mk \
+          file://fix-for-make-3.82.diff"
 SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
 B = "${WORKDIR}/build-${TARGET_SYS}"