]> code.ossystems Code Review - openembedded-core.git/commitdiff
ethtool: add ptest
authorGabriel Barbu <gabriel.barbu@enea.com>
Thu, 11 Jul 2013 13:28:08 +0000 (15:28 +0200)
committerSaul Wold <sgw@linux.intel.com>
Fri, 12 Jul 2013 17:12:12 +0000 (10:12 -0700)
Install ethtool test and run it as a ptest.

Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/ethtool/ethtool-3.10/run-ptest [new file with mode: 0644]
meta/recipes-extended/ethtool/ethtool_3.10.bb

diff --git a/meta/recipes-extended/ethtool/ethtool-3.10/run-ptest b/meta/recipes-extended/ethtool/ethtool-3.10/run-ptest
new file mode 100644 (file)
index 0000000..1e245da
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+make -k runtest-TESTS
index aa8b129787353c4e2afdb873263e775c8032247e..83587d90be31a25df68f270dbab44f2e903eaba5 100644 (file)
@@ -6,9 +6,23 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
 
-SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz"
+SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
+           file://run-ptest"
 
 SRC_URI[md5sum] = "b41deb37143dfb86934a8f52cea853d2"
 SRC_URI[sha256sum] = "62f0a9cea954c32a2bdc2d2ece295fda5b915cfea56f5de97b997d8ebaae0381"
 
-inherit autotools
+inherit autotools ptest
+RDEPENDS_${PN}-ptest += "make"
+
+do_compile_ptest() {
+   oe_runmake buildtest-TESTS
+}
+
+do_install_ptest () {
+   cp ${B}/Makefile                 ${D}${PTEST_PATH}
+   install ${B}/test-cmdline        ${D}${PTEST_PATH}
+   install ${B}/test-features       ${D}${PTEST_PATH}
+   install ${B}/ethtool             ${D}${PTEST_PATH}/ethtool
+   sed -i 's/^Makefile/_Makefile/'  ${D}${PTEST_PATH}/Makefile
+}