]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: make nscd optional
authorRoss Burton <ross@burtonini.com>
Mon, 28 Sep 2020 16:18:54 +0000 (17:18 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Sep 2020 14:01:46 +0000 (15:01 +0100)
NSCD itself is already packaged into its own package, but if it is never
going to be needed then it can be disabled and it won't be called from
glibc at all.  Add a PACKAGECONFIG for NSCD that is enabled by default.

As a side effect if NSCD is disable, glibc with and without systemd is
binary identical, which helps sstate reuse.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glibc/glibc_2.32.bb

index 7049e61625d1bd625ff0741b429a9e10041f5c5e..2a0e464385a1eaa06c918c2908c9ffb32d15743d 100644 (file)
@@ -69,13 +69,15 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
                 --enable-stackguard-randomization \
                 --disable-crypt \
                 --with-default-link \
-                --enable-nscd \
                 ${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
                 ${GLIBCPIE} \
                 ${GLIBC_EXTRA_OECONF}"
 
 EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
 
+PACKAGECONFIG ??= "nscd"
+PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"
+
 do_patch_append() {
     bb.build.exec_func('do_fix_readlib_c', d)
 }