]> code.ossystems Code Review - openembedded-core.git/commitdiff
powertop: fix segfault in dump mode
authorDexuan Cui <dexuan.cui@intel.com>
Fri, 27 Aug 2010 13:02:34 +0000 (21:02 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Sep 2010 08:50:48 +0000 (09:50 +0100)
The cause is: in dump mode, setup_windows() is not invoked so the
*_window variables, like cstate_window, are still NULL; later in
main() -> show_cstates(), the functions, like wrefresh(), will trigger
segfault.

After discussing in PowerTop mailling list, I think the right solution is
we should stub out the ncurses calls in dump mode.

(The patch was also sent to upstream PowerTop mailling list.)

This fixes [BUGID #195]:
Bug 195 - [sdk] powertop segfault when running with dump option

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
meta/recipes-kernel/powertop/powertop-1.13/stub_out_the_ncurses_calls_in_dump_mode.patch [new file with mode: 0644]
meta/recipes-kernel/powertop/powertop_1.13.bb

diff --git a/meta/recipes-kernel/powertop/powertop-1.13/stub_out_the_ncurses_calls_in_dump_mode.patch b/meta/recipes-kernel/powertop/powertop-1.13/stub_out_the_ncurses_calls_in_dump_mode.patch
new file mode 100644 (file)
index 0000000..e837765
--- /dev/null
@@ -0,0 +1,31 @@
+Running PowerTop in Poky in dump mode (with --dump) always ends with a
+segmentation fault.
+
+The cause is: in dump mode, setup_windows() is not invoked so the
+*_window variables, like cstate_window, are still NULL; later in
+main() -> show_cstates(), the functions, like wrefresh(), will trigger
+segfault.
+
+After discussing in PowerTop mailling list, I think the right solution is
+we should stub out the ncurses calls in dump mode.
+
+(The patch was also sent to upstream PowerTop mailling list.)
+
+Signed-off-by Dexuan Cui <dexuan.cui@intel.com>, 2010-08-20
+(this patch is licensed under GPLv2)
+
+--- a/display.c
++++ b/display.c
+@@ -44,6 +44,12 @@
+ static WINDOW *status_bar_window;
+ #define print(win, y, x, fmt, args...) do { if (dump) printf(fmt, ## args); else mvwprintw(win, y, x, fmt, ## args); } while (0)
++#define wattrset(win, c) do { if (!dump ) wattrset(win, c); } while (0)
++#define wbkgd(win, c) do { if (!dump ) wbkgd(win, c); } while (0)
++#define werase(win) do { if (!dump ) werase(win); } while (0)
++#define wrefresh(win) do { if (!dump ) wrefresh(win); } while (0)
++#define wattron(win, a) do { if (!dump ) wattron(win, a); } while (0)
++#define wattroff(win, a) do { if (!dump ) wattroff(win, a); } while (0)
+ char status_bar_slots[10][40];
index c52f2830b845cfec14e98ed7b67adb9854541b8c..c16f1aca630615302daf9c8932f218ae9b58d345 100644 (file)
@@ -12,7 +12,8 @@ REPENDS_${PN} = "pciutils"
 
 PR = "r0"
 
-SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
+           file://stub_out_the_ncurses_calls_in_dump_mode.patch"
 
 CFLAGS += "${LDFLAGS}"
 EXTRA_OEMAKE = "VERSION=\"${PV}\""