]> code.ossystems Code Review - openembedded-core.git/commitdiff
ipkg-utils: Fix problems with some versions of tar (from OE)
authorRichard Purdie <richard@openedhand.com>
Tue, 29 May 2007 14:03:18 +0000 (14:03 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 29 May 2007 14:03:18 +0000 (14:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1806 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
meta/packages/ipkg-utils/ipkg-utils/ipkg-py-tarfile.patch
meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb

index a0964d65b32479d1abea074ff0c6657ec60595e5..c57c14333ade44deb226466d770ffe9616fd206c 100644 (file)
@@ -1,7 +1,7 @@
 require ipkg-utils_${PV}.bb
 
 RDEPENDS = ""
-PR = "r11"
+PR = "r13"
 
 inherit native
 
index 94c57f63f234f5783f43ec3213b274143e2424ce..25eb2cce6f339e449d87b28c3ec5b244579b2474 100644 (file)
@@ -158,7 +158,7 @@ Index: ipkg-utils/ipkg.py
  
  class Version:
      """A class for holding parsed package version information."""
-@@ -131,78 +133,58 @@ class Package:
+@@ -131,78 +133,61 @@ class Package:
        self.section = None
          self.filename_header = None
        self.file_list = []
@@ -232,7 +232,10 @@ Index: ipkg-utils/ipkg.py
 +            tarStream = ar.open("control.tar.gz")
 +            tarf = tarfile.open("control.tar.gz", "r", tarStream)
 +
-+            control = tarf.extractfile("control")
++            try:
++              control = tarf.extractfile("control")
++            except KeyError:
++              control = tarf.extractfile("./control")
 +            self.read_control(control)
              control.close()
 -            if self.isdeb:
index 6ffe6fe679d5ddafa4c8c527180a6edecb146251..e8f52b65a4a1abd9701ca7dfab1df7f1ee099bd6 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "GPL"
 CONFLICTS = "ipkg-link"
 RDEPENDS = "python"
 SRCDATE = "20050404"
-PR = "r14"
+PR = "r15"
 
 SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \
            file://ipkg-utils-fix.patch;patch=1 \