]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 01:36:35 +0000 (01:36 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:39 +0000 (13:17 +0000)
Fix out of tree builds by removing assumptions about cwd and using
full paths to files in ${S}.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.9.bb

index cdfb5ff4bcad61f1eff7d1dd59151bff5e4d9211..6286771efa6ff1319b17430ef36dd03a2686dcc8 100644 (file)
@@ -358,13 +358,13 @@ FILES_${PN}-staticdev = " \
 
 do_configure() {
        # Disable tests!
-       echo "all:" > tests/Makefile.am
+       echo "all:" > ${S}/tests/Makefile.am
 
-       ./autogen.sh
+       ${S}/autogen.sh
 
        # NASTY hack to make sure configure files the right pkg-config file...
        sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
-           -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i configure
+           -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
 
        export varprefix=${localstatedir}
        oe_runconf