]> code.ossystems Code Review - openembedded-core.git/commitdiff
remove return in finally statement
authorCliff Brake <cbrake@bec-systems.com>
Wed, 16 Jun 2010 00:29:54 +0000 (17:29 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 2 Jul 2010 14:41:36 +0000 (15:41 +0100)
causes exceptions to not be handled after the finally statement

(Bitbake rev: 1a04610dea376340b9ea4c109f64995b4fd6ad02)

Signed-off-by: Cliff Brake <cbrake@bec-systems.com>
Signed-off-by: Chris Larson <clarson@kergoth.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake

index 65739106be6701d9a67610e26b4551bcd0ebdc07..c0eb713f55f3ff9a68ba43e43ee78aa0d113ea39 100755 (executable)
@@ -198,9 +198,9 @@ Default BBFILES are the .bb files in the current directory.""")
         except Exception, e:
             print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
             raise
-    finally:
-        serverConnection.terminate()
-        return return_value
+
+    serverConnection.terminate()
+    return return_value
 
 if __name__ == "__main__":
     ret = main()