]> code.ossystems Code Review - openembedded-core.git/commitdiff
bind: /var/cache/bind
authorJoe Slater <jslater@windriver.com>
Tue, 22 Mar 2016 20:36:19 +0000 (13:36 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Mar 2016 21:44:27 +0000 (21:44 +0000)
Change the ownership of /var/cache/bind to bind rather than root.

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/bind/bind_9.10.3-P3.bb

index da414c00dab02cea81f7609d6da981897989a162..fa057d52cf5668d73856e41a6aaeeb90b1b22139 100644 (file)
@@ -42,7 +42,7 @@ PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline"
 PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit"
 
 USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \
+USERADD_PARAM_${PN} = "--system --home ${localstatedir}/cache/bind --no-create-home \
                        --user-group bind"
 
 INITSCRIPT_NAME = "bind"
@@ -72,7 +72,7 @@ do_install_append() {
        rm "${D}${mandir}/man1/nslookup.1"
        rmdir "${D}${localstatedir}/run"
        rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
-       install -d "${D}${localstatedir}/cache/bind"
+       install -d -o bind "${D}${localstatedir}/cache/bind"
        install -d "${D}${sysconfdir}/bind"
        install -d "${D}${sysconfdir}/init.d"
        install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
@@ -80,7 +80,6 @@ do_install_append() {
        sed -i -e '1s,#!.*python,#! /usr/bin/env python,' ${D}${sbindir}/dnssec-coverage ${D}${sbindir}/dnssec-checkds
 
        # Install systemd related files
-       install -d ${D}${localstatedir}/cache/bind
        install -d ${D}${sbindir}
        install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
        install -d ${D}${systemd_unitdir}/system