]> code.ossystems Code Review - openembedded-core.git/commitdiff
squashfs-tools: Add support for LZO and LZ4 compression
authorMike Looijmans <mike.looijmans@topic.nl>
Tue, 12 Aug 2014 07:54:58 +0000 (09:54 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 Aug 2014 17:19:54 +0000 (18:19 +0100)
For systems that want to optimize for speed rather than size, LZO is
usually a better choice than gzip or XZ. Kernel support for LZO has
been available since 2.6.29.

LZ4 support isn't in the mainline kernel yet, but we might as well add
it now for those who want to experiment with it.

Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/squashfs-tools/squashfs-tools_4.3.bb

index 54fd3bb85faf313cadfd893c9d266ceab4fbc372..e3783fd81d409d2a26c30fbf1c5839225c03f656 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPL-2 & PD"
 LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
                    "
-DEPENDS = "attr zlib xz"
+DEPENDS = "attr zlib xz lzo lz4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \
            http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
@@ -23,7 +23,7 @@ S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
 # EXTRA_OEMAKE is typically: -e MAKEFLAGS=
 # the -e causes problems as CFLAGS is modified in the Makefile, so
 # we redefine EXTRA_OEMAKE here
-EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1"
+EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
 
 do_compile() {
         oe_runmake mksquashfs