]> code.ossystems Code Review - openembedded-core.git/commitdiff
Take patch from upstream to check Xlib instead of Xt for X presence
authorRoss Burton <ross@openedhand.com>
Thu, 26 Jan 2006 15:17:51 +0000 (15:17 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 26 Jan 2006 15:17:51 +0000 (15:17 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@239 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch [new file with mode: 0644]
openembedded/packages/autoconf/autoconf_2.59.bb

diff --git a/openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch b/openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch
new file mode 100644 (file)
index 0000000..9838693
--- /dev/null
@@ -0,0 +1,35 @@
+Index: lib/autoconf/libs.m4
+===================================================================
+RCS file: /cvsroot/autoconf/autoconf/lib/autoconf/libs.m4,v
+retrieving revision 1.13
+diff -p -u -r1.13 libs.m4
+--- autoconf-2.59/lib/autoconf/libs.m4 6 Sep 2005 15:34:06 -0000       1.13
++++ autoconf-2.59/lib/autoconf/libs.m4 18 Sep 2005 17:09:58 -0000
+@@ -265,13 +265,13 @@ ac_x_header_dirs='
+ /usr/openwin/share/include'
+ if test "$ac_x_includes" = no; then
+-  # Guess where to find include files, by looking for Intrinsic.h.
++  # Guess where to find include files, by looking for Xlib.h.
+   # First, try using that file with no special directory specified.
+-  AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Intrinsic.h>])],
++  AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Xlib.h>])],
+ [# We can compile using X headers with no special include directory.
+ ac_x_includes=],
+ [for ac_dir in $ac_x_header_dirs; do
+-  if test -r "$ac_dir/X11/Intrinsic.h"; then
++  if test -r "$ac_dir/X11/Xlib.h"; then
+     ac_x_includes=$ac_dir
+     break
+   fi
+@@ -284,7 +284,7 @@ if test "$ac_x_libraries" = no; then
+   # Don't add to $LIBS permanently.
+   ac_save_LIBS=$LIBS
+   LIBS="-lXt $LIBS"
+-  AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Intrinsic.h>],
+-                                [XtMalloc (0)])],
++  AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Xlib.h>],
++                                [XrmInitialize ()])],
+                [LIBS=$ac_save_LIBS
+ # We can link X programs with no special library path.
+ ac_x_libraries=],
\ No newline at end of file
index 8636a77787219e5e30735f5aeb11cf1ff7bcfe3d..3cc962da01883b945a3236a09d6eda16dd76bedd 100644 (file)
@@ -6,7 +6,7 @@ SECTION = "devel"
 DEPENDS += "m4-native"
 RDEPENDS_${PN} = "m4 gnu-config"
 RRECOMMENDS_${PN} = "automake"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
           file://program_prefix.patch;patch=1 \
@@ -17,5 +17,6 @@ SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
           file://autoconf259-update-configscripts.patch;patch=1 \
           file://autoheader-nonfatal-warnings.patch;patch=1 \
           file://sizeof_types.patch;patch=1 \
+          file://autoconf-x.patch;patch=1 \
           ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
 inherit autotools