]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: manually cleanup sysck
authorJérémy Rosen <jeremy.rosen@smile.fr>
Wed, 7 Sep 2016 09:08:48 +0000 (11:08 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Sep 2016 14:17:39 +0000 (15:17 +0100)
version 5.4.1 of rpm was not properly distclean before release, which
causes problems when cross-compiling.

The previous version this recipe called make distclean, but that would
trigger a call to ./configure which would fail when no gcc is
available and make the whole do_configure fail further down the line

This patch manually removes the files from the recipe.

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/rpm/rpm_5.4.16.bb

index 55acd25b1ceeca29f4b7920201cdf6617c957786..9f78deeea282f6ed324b052bd29c87a9e18b7ad5 100644 (file)
@@ -527,7 +527,7 @@ do_configure() {
        sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
            -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
 
-       ( cd ${S}/syck ; set +e ; rm -- -l* ; make distclean ) || :
+       ( cd ${S}/syck ; set +e ; rm -- -l* ; rm Makefile config.h config.status lib/Makefile libtool stamp-h1 tests/.deps tests/Makefile  ) || :
 
        export varprefix=${localstatedir}
        oe_runconf