]> code.ossystems Code Review - openembedded-core.git/commitdiff
samba: Add from OE but split libtdb out into its own package
authorRichard Purdie <rpurdie@linux.intel.com>
Sat, 16 May 2009 08:56:39 +0000 (09:56 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Sat, 16 May 2009 08:56:39 +0000 (09:56 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
13 files changed:
meta-moblin/packages/samba/files/config-h.patch [new file with mode: 0644]
meta-moblin/packages/samba/files/config-lfs.patch [new file with mode: 0644]
meta-moblin/packages/samba/files/configure-3.3.0.patch [new file with mode: 0644]
meta-moblin/packages/samba/files/configure.patch [new file with mode: 0644]
meta-moblin/packages/samba/files/init [new file with mode: 0644]
meta-moblin/packages/samba/files/mtab.patch [new file with mode: 0644]
meta-moblin/packages/samba/files/quota.patch [new file with mode: 0644]
meta-moblin/packages/samba/files/smb.conf [new file with mode: 0644]
meta-moblin/packages/samba/files/tdb.pc [new file with mode: 0644]
meta-moblin/packages/samba/files/volatiles.03_samba [new file with mode: 0644]
meta-moblin/packages/samba/samba-basic.inc [new file with mode: 0644]
meta-moblin/packages/samba/samba.inc [new file with mode: 0644]
meta-moblin/packages/samba/samba_3.3.0.bb [new file with mode: 0644]

diff --git a/meta-moblin/packages/samba/files/config-h.patch b/meta-moblin/packages/samba/files/config-h.patch
new file mode 100644 (file)
index 0000000..eeb2268
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN source.old//include/config.h.in source//include/config.h.in
+--- source.old//include/config.h.in    2008-11-20 14:45:04.000000000 +0000
++++ source//include/config.h.in        2008-11-30 21:04:17.990008933 +0000
+@@ -2672,7 +2672,7 @@
+ #undef USE_SETEUID
+ /* Whether setresuid() is available */
+-#undef USE_SETRESUID
++#define USE_SETRESUID 1
+ /* Whether setreuid() is available */
+ #undef USE_SETREUID
diff --git a/meta-moblin/packages/samba/files/config-lfs.patch b/meta-moblin/packages/samba/files/config-lfs.patch
new file mode 100644 (file)
index 0000000..b37ed69
--- /dev/null
@@ -0,0 +1,47 @@
+Cache the check for Linux LFS support, so it can be prepopulated from 
+the site cache for configure variables for cross-compiling.  Without this,
+samba gets the idea that it can use dirent64 and friends without defining
+the flags it needs to get it, such as _GNU_SOURCE and _LARGEFILE64_SOURCE.
+
+Symptoms of getting the configuration wrong on cross-compile inculde
+warnings such as
+
+  smbd/trans2.c: In function `get_lanman2_dir_entry':
+  smbd/trans2.c:1065: warning: right shift count >= width of type
+
+and errors like
+
+  smbd/vfs.c:630: error: dereferencing pointer to incomplete type
+
+(when trying to dereference dirent64.)
+
+--- source/configure.in.orig   2005-05-29 14:46:18.000000000 -0700
++++ source/configure.in        2005-05-29 14:51:57.000000000 -0700
+@@ -588,7 +588,7 @@
+ # Tests for linux LFS support. Need kernel 2.4 and glibc2.2 or greater support.
+ #
+     *linux*)
+-        AC_MSG_CHECKING([for LFS support])
++       AC_CACHE_CHECK([for LFS support], samba_cv_LINUX_LFS_SUPPORT,[
+         old_CPPFLAGS="$CPPFLAGS"
+         CPPFLAGS="-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE $CPPFLAGS"
+        AC_TRY_RUN([
+@@ -627,15 +627,14 @@
+        exit(1);
+ #endif
+ }
+-], [LINUX_LFS_SUPPORT=yes], [LINUX_LFS_SUPPORT=no], [LINUX_LFS_SUPPORT=cross])
+-      CPPFLAGS="$old_CPPFLAGS"
+-      if test x$LINUX_LFS_SUPPORT = xyes ; then
++], [samba_cv_LINUX_LFS_SUPPORT=yes], [samba_cv_LINUX_LFS_SUPPORT=no], [samba_cv_LINUX_LFS_SUPPORT=cross])
++      CPPFLAGS="$old_CPPFLAGS"])
++      if test x"$samba_cv_LINUX_LFS_SUPPORT" = x"yes" ; then
+               CPPFLAGS="-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE $CPPFLAGS"
+               AC_DEFINE(_LARGEFILE64_SOURCE, 1, [Whether to enable large file support])
+               AC_DEFINE(_FILE_OFFSET_BITS, 64, [File offset bits])
+               AC_DEFINE(_GNU_SOURCE, 1, [Whether to use GNU libc extensions])
+       fi
+-      AC_MSG_RESULT([$LINUX_LFS_SUPPORT])
+       ;;
+ #
diff --git a/meta-moblin/packages/samba/files/configure-3.3.0.patch b/meta-moblin/packages/samba/files/configure-3.3.0.patch
new file mode 100644 (file)
index 0000000..a2e2544
--- /dev/null
@@ -0,0 +1,87 @@
+Index: source/configure
+===================================================================
+--- source.orig/configure      2009-01-27 07:53:11.000000000 +0000
++++ source/configure   2009-05-15 12:51:02.000000000 +0100
+@@ -43860,13 +43860,7 @@
+     *linux*)
+        # glibc <= 2.3.2 has a broken getgrouplist
+        if test "$cross_compiling" = yes; then
+-  { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-$as_echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }; }
++linux_getgrouplist_ok=no
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+Index: source/configure.in
+===================================================================
+--- source.orig/configure.in   2009-05-15 12:51:01.000000000 +0100
++++ source/configure.in        2009-05-15 13:02:22.000000000 +0100
+@@ -280,6 +280,8 @@
+ fi
+ AC_SUBST(BROKEN_CC)
++AC_TRY_COMPILE([],[(void)sizeof(char[-1])],AC_MSG_ERROR([configure's compilation assert doesn't work with $CC]))
++
+ dnl Check if the C compiler understands -Werror
+ AC_CACHE_CHECK([that the C compiler understands -Werror],samba_cv_HAVE_Werror, [
+  AC_TRY_RUN_STRICT([
+@@ -330,25 +332,11 @@
+ # a runtime test is needed here
+ AC_SUBST(PIDL_ARGS)
+ AC_CACHE_CHECK([that the C compiler understands negative enum values],samba_cv_CC_NEGATIVE_ENUM_VALUES, [
+-    AC_TRY_RUN(
++    AC_TRY_COMPILE([],
+ [
+-      #include <stdio.h>
+       enum negative_values { NEGATIVE_VALUE = 0xFFFFFFFF };
+-      int main(void) {
+-              enum negative_values v1 = NEGATIVE_VALUE;
+-              unsigned v2 = NEGATIVE_VALUE;
+-
+-              if (v1 != 0xFFFFFFFF) {
+-                      printf("%u != 0xFFFFFFFF\n", v1);
+-                      return 1;
+-              }
+-              if (v2 != 0xFFFFFFFF) {
+-                      printf("%u != 0xFFFFFFFF\n", v2);
+-                      return 1;
+-              }
+-
+-              return 0;
+-      }
++      (void)sizeof(char[1-2*(            (unsigned)NEGATIVE_VALUE != 0xFFFFFFFF)]);
++      (void)sizeof(char[1-2*((enum negative_values)NEGATIVE_VALUE != 0xFFFFFFFF)]);
+ ],
+       samba_cv_CC_NEGATIVE_ENUM_VALUES=yes,samba_cv__CC_NEGATIVE_ENUM_VALUES=no)])
+ if test x"$samba_cv_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
+@@ -1223,22 +1211,12 @@
+ case "$host_os" in
+     *linux*)
+        # glibc <= 2.3.2 has a broken getgrouplist
+-       AC_TRY_RUN([
+-#include <unistd.h>
++      AC_TRY_COMPILE([ 
+ #include <sys/utsname.h>
+-main() {
+-       /* glibc up to 2.3 has a broken getgrouplist */
++],[
+ #if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
+-       int libc_major = __GLIBC__;
+-       int libc_minor = __GLIBC_MINOR__;
+-
+-       if (libc_major < 2)
+-              exit(1);
+-       if ((libc_major == 2) && (libc_minor <= 3))
+-              exit(1);
++      (void)sizeof(char[1-2*(__GLIBC__ < 2 || __GLIBC__ == 2 && __GLIBC_MINOR__ <= 3)]);
+ #endif
+-       exit(0);
+-}
+ ], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
+        if test x"$linux_getgrouplist_ok" = x"yes"; then
+           AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
diff --git a/meta-moblin/packages/samba/files/configure.patch b/meta-moblin/packages/samba/files/configure.patch
new file mode 100644 (file)
index 0000000..b7ba287
--- /dev/null
@@ -0,0 +1,179 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- source/configure.in~configure      2003-12-14 22:36:25.000000000 -0500
++++ source/configure.in        2004-01-26 14:33:15.000000000 -0500
+@@ -959,7 +959,7 @@
+ #endif
+        exit(0);
+ }
+-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
++], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no], [linux_getgrouplist_ok=cross])
+        if test x"$linux_getgrouplist_ok" = x"yes"; then
+           AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
+        fi
+--- source/aclocal.m4~configure        2004-01-26 14:33:15.000000000 -0500
++++ source/aclocal.m4  2004-01-26 17:34:28.000000000 -0500
+@@ -2,7 +2,7 @@
+ dnl if the cache file is inconsistent with the current host,
+ dnl target and build system types, execute CMD or print a default
+ dnl error message.
+-AC_DEFUN(AC_VALIDATE_CACHE_SYSTEM_TYPE, [
++AC_DEFUN([AC_VALIDATE_CACHE_SYSTEM_TYPE], [
+     AC_REQUIRE([AC_CANONICAL_SYSTEM])
+     AC_MSG_CHECKING([config.cache system type])
+     if { test x"${ac_cv_host_system_type+set}" = x"set" &&
+@@ -24,7 +24,7 @@
+ dnl test whether dirent has a d_off member
+-AC_DEFUN(AC_DIRENT_D_OFF,
++AC_DEFUN([AC_DIRENT_D_OFF],
+ [AC_CACHE_CHECK([for d_off in dirent], ac_cv_dirent_d_off,
+ [AC_TRY_COMPILE([
+ #include <unistd.h>
+@@ -38,7 +38,7 @@
+ dnl Mark specified module as shared
+ dnl SMB_MODULE(name,static_files,shared_files,subsystem,whatif-static,whatif-shared)
+-AC_DEFUN(SMB_MODULE,
++AC_DEFUN([SMB_MODULE],
+ [
+       AC_MSG_CHECKING([how to build $1])
+       if test "$[MODULE_][$1]"; then
+@@ -68,7 +68,7 @@
+       fi
+ ])
+-AC_DEFUN(SMB_SUBSYSTEM,
++AC_DEFUN([SMB_SUBSYSTEM],
+ [
+       AC_SUBST($1_STATIC)
+       AC_SUBST($1_MODULES)
+@@ -77,7 +77,7 @@
+ ])
+ dnl AC_PROG_CC_FLAG(flag)
+-AC_DEFUN(AC_PROG_CC_FLAG,
++AC_DEFUN([AC_PROG_CC_FLAG],
+ [AC_CACHE_CHECK(whether ${CC-cc} accepts -$1, ac_cv_prog_cc_$1,
+ [echo 'void f(){}' > conftest.c
+ if test -z "`${CC-cc} -$1 -c conftest.c 2>&1`"; then
+@@ -91,7 +91,7 @@
+ dnl see if a declaration exists for a function or variable
+ dnl defines HAVE_function_DECL if it exists
+ dnl AC_HAVE_DECL(var, includes)
+-AC_DEFUN(AC_HAVE_DECL,
++AC_DEFUN([AC_HAVE_DECL],
+ [
+  AC_CACHE_CHECK([for $1 declaration],ac_cv_have_$1_decl,[
+     AC_TRY_COMPILE([$2],[int i = (int)$1],
+@@ -105,7 +105,7 @@
+ dnl check for a function in a library, but don't
+ dnl keep adding the same library to the LIBS variable.
+ dnl AC_LIBTESTFUNC(lib,func)
+-AC_DEFUN(AC_LIBTESTFUNC,
++AC_DEFUN([AC_LIBTESTFUNC],
+ [case "$LIBS" in
+   *-l$1*) AC_CHECK_FUNCS($2) ;;
+   *) AC_CHECK_LIB($1, $2) 
+@@ -223,7 +223,7 @@
+ dnl Define an AC_DEFINE with ifndef guard.
+ dnl AC_N_DEFINE(VARIABLE [, VALUE])
+-define(AC_N_DEFINE,
++define([AC_N_DEFINE],
+ [cat >> confdefs.h <<\EOF
+ [#ifndef] $1
+ [#define] $1 ifelse($#, 2, [$2], $#, 3, [$2], 1)
+@@ -233,14 +233,14 @@
+ dnl Add an #include
+ dnl AC_ADD_INCLUDE(VARIABLE)
+-define(AC_ADD_INCLUDE,
++define([AC_ADD_INCLUDE],
+ [cat >> confdefs.h <<\EOF
+ [#include] $1
+ EOF
+ ])
+ dnl Copied from libtool.m4
+-AC_DEFUN(AC_PROG_LD_GNU,
++AC_DEFUN([AC_PROG_LD_GNU],
+ [AC_CACHE_CHECK([if the linker ($LD) is GNU ld], ac_cv_prog_gnu_ld,
+ [# I'd rather use --version here, but apparently some GNU ld's only accept -v.
+ if $LD -v 2>&1 </dev/null | egrep '(GNU|with BFD)' 1>&5; then
+@@ -259,7 +259,7 @@
+ dnl AM_PATH_XML2([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+ dnl Test for XML, and define XML_CFLAGS and XML_LIBS
+ dnl
+-AC_DEFUN(AM_PATH_XML2,[ 
++AC_DEFUN([AM_PATH_XML2],[ 
+ AC_ARG_WITH(xml-prefix,
+             [  --with-xml-prefix=PFX   Prefix where libxml is installed (optional)],
+             xml_config_prefix="$withval", xml_config_prefix="")
+@@ -443,7 +443,7 @@
+ dnl AM_PATH_MYSQL([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+ dnl Test for MYSQL, and define MYSQL_CFLAGS and MYSQL_LIBS
+ dnl
+-AC_DEFUN(AM_PATH_MYSQL,
++AC_DEFUN([AM_PATH_MYSQL],
+ [dnl
+ dnl Get the cflags and libraries from the mysql_config script
+ dnl
+@@ -485,7 +485,7 @@
+ ])
+ dnl Removes -I/usr/include/? from given variable
+-AC_DEFUN(CFLAGS_REMOVE_USR_INCLUDE,[
++AC_DEFUN([CFLAGS_REMOVE_USR_INCLUDE],[
+   ac_new_flags=""
+   for i in [$]$1; do
+     case [$]i in
+@@ -497,7 +497,7 @@
+ ])
+     
+ dnl Removes -L/usr/lib/? from given variable
+-AC_DEFUN(LIB_REMOVE_USR_LIB,[
++AC_DEFUN([LIB_REMOVE_USR_LIB],[
+   ac_new_flags=""
+   for i in [$]$1; do
+     case [$]i in
+@@ -510,7 +510,7 @@
+ dnl From Bruno Haible.
+-AC_DEFUN(jm_ICONV,
++AC_DEFUN([jm_ICONV],
+ [
+   dnl Some systems have iconv in libc, some have it in libiconv (OSF/1 and
+   dnl those with the standalone portable libiconv installed).
+@@ -607,7 +607,7 @@
+   fi
+ ])
+-AC_DEFUN(rjs_CHARSET,[
++AC_DEFUN([rjs_CHARSET],[
+   dnl Find out if we can convert from $1 to UCS2-LE
+   AC_MSG_CHECKING([can we convert from $1 to UCS2-LE?])
+   AC_TRY_RUN([
+@@ -625,7 +625,7 @@
+ dnl CFLAGS_ADD_DIR(CFLAGS, $INCDIR)
+ dnl This function doesn't add -I/usr/include into CFLAGS
+-AC_DEFUN(CFLAGS_ADD_DIR,[
++AC_DEFUN([CFLAGS_ADD_DIR],[
+ if test "$2" != "/usr/include" ; then
+     $1="$$1 -I$2"
+ fi
+@@ -633,7 +633,7 @@
+ dnl LIB_ADD_DIR(LDFLAGS, $LIBDIR)
+ dnl This function doesn't add -L/usr/lib into LDFLAGS
+-AC_DEFUN(LIB_ADD_DIR,[
++AC_DEFUN([LIB_ADD_DIR],[
+ if test "$2" != "/usr/lib" ; then
+     $1="$$1 -L$2"
+ fi
diff --git a/meta-moblin/packages/samba/files/init b/meta-moblin/packages/samba/files/init
new file mode 100644 (file)
index 0000000..cb57b17
--- /dev/null
@@ -0,0 +1,58 @@
+#! /bin/sh 
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/samba and type
+# > update-rc.d samba defaults 60
+#
+
+
+smbd=/usr/sbin/smbd
+test -x "$smbd" || exit 0
+nmbd=/usr/sbin/nmbd
+test -x "$nmbd" || exit 0
+
+
+case "$1" in
+  start)
+    echo -n "Starting Samba: smbd"
+    start-stop-daemon --start --quiet --exec $smbd
+    echo -n " nmbd"
+    start-stop-daemon --start --quiet --exec $nmbd
+    echo "."
+    ;;
+  stop)
+    echo -n "Stopping Samba: smbd"
+    start-stop-daemon --stop --quiet --pidfile /var/run/smbd.pid
+    echo -n " nmbd"
+    start-stop-daemon --stop --quiet --pidfile /var/run/nmbd.pid
+    echo "."
+    ;;
+  reload|force-reload)
+    start-stop-daemon --stop --quiet --signal 1 --exec $smbd
+    start-stop-daemon --stop --quiet --signal 1 --exec $nmbd
+    ;;
+  restart)
+    echo -n "Stopping Samba: smbd"
+    start-stop-daemon --stop --quiet --pidfile /var/run/smbd.pid
+    echo -n " nmbd"
+    start-stop-daemon --stop --quiet --pidfile /var/run/nmbd.pid
+    echo ""
+    echo -n "Waiting for samba processes to die off"
+    for i in 1 2 3 ;
+    do
+        sleep 1
+        echo -n "."
+    done
+    echo ""
+    echo -n "Starting Samba: smbd"
+    start-stop-daemon --start --quiet --exec $smbd
+    echo -n " nmbd"
+    start-stop-daemon --start --quiet --exec $nmbd
+    echo "."
+    ;;
+  *)
+    echo "Usage: /etc/init.d/samba {start|stop|reload|restart|force-reload}"
+    exit 1
+esac
+
+exit 0
\ No newline at end of file
diff --git a/meta-moblin/packages/samba/files/mtab.patch b/meta-moblin/packages/samba/files/mtab.patch
new file mode 100644 (file)
index 0000000..2ee8ba0
--- /dev/null
@@ -0,0 +1,11 @@
+diff -urN source/client/mtab.c samba-3.2.7//source/client/mtab.c
+--- source/client/mtab.c       2008-12-19 13:57:33.000000000 +0000
++++ source/client/mtab.c       2009-01-09 23:14:00.717671075 +0000
+@@ -32,6 +32,7 @@
+ #include <errno.h>
+ #include <stdio.h>
+ #include <sys/time.h>
++#include <sys/stat.h>
+ #include <time.h>
+ #include <fcntl.h>
+ #include <mntent.h>
diff --git a/meta-moblin/packages/samba/files/quota.patch b/meta-moblin/packages/samba/files/quota.patch
new file mode 100644 (file)
index 0000000..6f42ff8
--- /dev/null
@@ -0,0 +1,11 @@
+--- lib/sysquotas_4A.c.old     2005-07-03 17:16:00.000000000 +0200
++++ lib/sysquotas_4A.c 2005-07-03 17:10:09.000000000 +0200
+@@ -28,6 +28,8 @@
+ /* long quotactl(int cmd, char *special, qid_t id, caddr_t addr) */
+ /* this is used by: HPUX,IRIX */
++ #define _LINUX_QUOTA_VERSION 1
++
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
diff --git a/meta-moblin/packages/samba/files/smb.conf b/meta-moblin/packages/samba/files/smb.conf
new file mode 100644 (file)
index 0000000..f07e3e4
--- /dev/null
@@ -0,0 +1,266 @@
+# This is the main Samba configuration file. You should read the
+# smb.conf(5) manual page in order to understand the options listed
+# here. Samba has a huge number of configurable options (perhaps too
+# many!) most of which are not shown in this example
+#
+# For a step to step guide on installing, configuring and using samba, 
+# read the Samba-HOWTO-Collection. This may be obtained from:
+#  http://www.samba.org/samba/docs/Samba-HOWTO-Collection.pdf
+#
+# Many working examples of smb.conf files can be found in the 
+# Samba-Guide which is generated daily and can be downloaded from: 
+#  http://www.samba.org/samba/docs/Samba-Guide.pdf
+#
+# Any line which starts with a ; (semi-colon) or a # (hash) 
+# is a comment and is ignored. In this example we will use a #
+# for commentry and a ; for parts of the config file that you
+# may wish to enable
+#
+# NOTE: Whenever you modify this file you should run the command "testparm"
+# to check that you have not made any basic syntactic errors. 
+#
+#======================= Global Settings =====================================
+[global]
+
+# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
+   workgroup = MYGROUP
+
+# server string is the equivalent of the NT Description field
+   server string = Samba Server
+
+# Security mode. Defines in which mode Samba will operate. Possible 
+# values are share, user, server, domain and ads. Most people will want 
+# user level security. See the Samba-HOWTO-Collection for details.
+   security = user
+
+# This option is important for security. It allows you to restrict
+# connections to machines which are on your local network. The
+# following example restricts access to two C class networks and
+# the "loopback" interface. For more examples of the syntax see
+# the smb.conf man page
+;   hosts allow = 192.168.1. 192.168.2. 127.
+
+# If you want to automatically load your printer list rather
+# than setting them up individually then you'll need this
+   load printers = yes
+
+# you may wish to override the location of the printcap file
+;   printcap name = /etc/printcap
+
+# on SystemV system setting printcap name to lpstat should allow
+# you to automatically obtain a printer list from the SystemV spool
+# system
+;   printcap name = lpstat
+
+# It should not be necessary to specify the print system type unless
+# it is non-standard. Currently supported print systems include:
+# bsd, cups, sysv, plp, lprng, aix, hpux, qnx
+;   printing = cups
+
+# Uncomment this if you want a guest account, you must add this to /etc/passwd
+# otherwise the user "nobody" is used
+;  guest account = pcguest
+
+# this tells Samba to use a separate log file for each machine
+# that connects
+   log file = /var/log/samba/log.%m
+
+# Put a capping on the size of the log files (in Kb).
+   max log size = 50
+
+# Use password server option only with security = server
+# The argument list may include:
+#   password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
+# or to auto-locate the domain controller/s
+#   password server = *
+;   password server = <NT-Server-Name>
+
+# Use the realm option only with security = ads
+# Specifies the Active Directory realm the host is part of
+;   realm = MY_REALM
+
+# Backend to store user information in. New installations should 
+# use either tdbsam or ldapsam. smbpasswd is available for backwards 
+# compatibility. tdbsam requires no further configuration.
+;   passdb backend = tdbsam
+
+# Using the following line enables you to customise your configuration
+# on a per machine basis. The %m gets replaced with the netbios name
+# of the machine that is connecting.
+# Note: Consider carefully the location in the configuration file of
+#       this line.  The included file is read at that point.
+;   include = /usr/local/samba/lib/smb.conf.%m
+
+# Configure Samba to use multiple interfaces
+# If you have multiple network interfaces then you must list them
+# here. See the man page for details.
+;   interfaces = 192.168.12.2/24 192.168.13.2/24 
+
+# Browser Control Options:
+# set local master to no if you don't want Samba to become a master
+# browser on your network. Otherwise the normal election rules apply
+;   local master = no
+
+# OS Level determines the precedence of this server in master browser
+# elections. The default value should be reasonable
+;   os level = 33
+
+# Domain Master specifies Samba to be the Domain Master Browser. This
+# allows Samba to collate browse lists between subnets. Don't use this
+# if you already have a Windows NT domain controller doing this job
+;   domain master = yes 
+
+# Preferred Master causes Samba to force a local browser election on startup
+# and gives it a slightly higher chance of winning the election
+;   preferred master = yes
+
+# Enable this if you want Samba to be a domain logon server for 
+# Windows95 workstations. 
+;   domain logons = yes
+
+# if you enable domain logons then you may want a per-machine or
+# per user logon script
+# run a specific logon batch file per workstation (machine)
+;   logon script = %m.bat
+# run a specific logon batch file per username
+;   logon script = %U.bat
+
+# Where to store roving profiles (only for Win95 and WinNT)
+#        %L substitutes for this servers netbios name, %U is username
+#        You must uncomment the [Profiles] share below
+;   logon path = \\%L\Profiles\%U
+
+# Windows Internet Name Serving Support Section:
+# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
+;   wins support = yes
+
+# WINS Server - Tells the NMBD components of Samba to be a WINS Client
+#       Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
+;   wins server = w.x.y.z
+
+# WINS Proxy - Tells Samba to answer name resolution queries on
+# behalf of a non WINS capable client, for this to work there must be
+# at least one  WINS Server on the network. The default is NO.
+;   wins proxy = yes
+
+# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
+# via DNS nslookups. The default is NO.
+   dns proxy = no 
+
+# These scripts are used on a domain controller or stand-alone 
+# machine to add or delete corresponding unix accounts
+;  add user script = /usr/sbin/useradd %u
+;  add group script = /usr/sbin/groupadd %g
+;  add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
+;  delete user script = /usr/sbin/userdel %u
+;  delete user from group script = /usr/sbin/deluser %u %g
+;  delete group script = /usr/sbin/groupdel %g
+
+
+#============================ Share Definitions ==============================
+[homes]
+   comment = Home Directories
+   browseable = yes
+   writable = yes
+
+# Un-comment the following and create the netlogon directory for Domain Logons
+; [netlogon]
+;   comment = Network Logon Service
+;   path = /usr/local/samba/lib/netlogon
+;   guest ok = yes
+;   writable = no
+;   share modes = no
+
+
+# Un-comment the following to provide a specific roving profile share
+# the default is to use the user's home directory
+;[Profiles]
+;    path = /usr/local/samba/profiles
+;    browseable = no
+;    guest ok = yes
+
+
+# NOTE: If you have a BSD-style print system there is no need to 
+# specifically define each individual printer
+[printers]
+   comment = All Printers
+   path = /var/spool/samba
+   browseable = no
+# Set public = yes to allow user 'guest account' to print
+   guest ok = no
+   writable = no
+   printable = yes
+
+# This one is useful for people to share files
+;[tmp]
+;   comment = Temporary file space
+;   path = /tmp
+;   read only = no
+;   public = yes
+
+# A publicly accessible directory, but read only, except for people in
+# the "staff" group
+;[public]
+;   comment = Public Stuff
+;   path = /home/samba
+;   public = yes
+;   writable = yes
+;   printable = no
+;   write list = @staff
+
+# Other examples. 
+#
+# A private printer, usable only by fred. Spool data will be placed in fred's
+# home directory. Note that fred must have write access to the spool directory,
+# wherever it is.
+;[fredsprn]
+;   comment = Fred's Printer
+;   valid users = fred
+;   path = /homes/fred
+;   printer = freds_printer
+;   public = no
+# A private directory, usable only by fred. Note that fred requires write
+# access to the directory.
+;[fredsdir]
+;   comment = Fred's Service
+;   path = /usr/somewhere/private
+;   valid users = fred
+;   public = no
+;   writable = yes
+;   printable = no
+
+# a service which has a different directory for each machine that connects
+# this allows you to tailor configurations to incoming machines. You could
+# also use the %U option to tailor it by user name.
+# The %m gets replaced with the machine name that is connecting.
+;[pchome]
+;  comment = PC Directories
+;  path = /usr/pc/%m
+;  public = no
+;  writable = yes
+
+# A publicly accessible directory, read/write to all users. Note that all files
+# created in the directory by users will be owned by the default user, so
+# any user with access can delete any other user's files. Obviously this
+# directory must be writable by the default user. Another user could of course
+# be specified, in which case all files would be owned by that user instead.
+;[public]
+;   path = /usr/somewhere/else/public
+;   public = yes
+;   only guest = yes
+;   writable = yes
+;   printable = no
+
+# The following two entries demonstrate how to share a directory so that two
+# users can place files there that will be owned by the specific users. In this
+# setup, the directory should be writable by both users and should have the
+# sticky bit set on it to prevent abuse. Obviously this could be extended to
+# as many users as required.
+;[myshare]
+;   comment = Mary's and Fred's stuff
+;   path = /usr/somewhere/shared
+;   valid users = mary fred
+;   public = no
+;   writable = yes
+;   printable = no
+;   create mask = 0765
diff --git a/meta-moblin/packages/samba/files/tdb.pc b/meta-moblin/packages/samba/files/tdb.pc
new file mode 100644 (file)
index 0000000..6307a20
--- /dev/null
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=/usr
+libdir=/usr/lib
+includedir=/usr/include
+
+Name: tdb
+Description: A trivial database
+Version: 1.1.2
+Libs: -L${libdir} -ltdb
+Cflags: -I${includedir} 
+URL: http://tdb.samba.org/
diff --git a/meta-moblin/packages/samba/files/volatiles.03_samba b/meta-moblin/packages/samba/files/volatiles.03_samba
new file mode 100644 (file)
index 0000000..469bc9e
--- /dev/null
@@ -0,0 +1,2 @@
+# <type> <owner> <group> <mode> <path> <linksource>
+d root root 0755 /var/log/samba none
diff --git a/meta-moblin/packages/samba/samba-basic.inc b/meta-moblin/packages/samba/samba-basic.inc
new file mode 100644 (file)
index 0000000..209ba8f
--- /dev/null
@@ -0,0 +1,25 @@
+SRC_URI += "file://config-lfs.patch;patch=1 \
+            file://quota.patch;patch=1;pnum=0 \
+            "
+
+EXTRA_OECONF += "\
+        --without-ads \
+        --without-winbind \
+        --without-ldap \
+        --without-krb5"
+
+PACKAGES =+ "libsmbclient libsmbclient-dev cifs cifs-doc swat libtdb"
+
+RCONFLICTS_${PN} = "samba-ads"
+RCONFLICTS_libsmbclient = "libsmbclient-ads"
+RCONFLICTS_libsmbclient-dev = "libsmbclient-ads-dev"
+RCONFLICTS_cifs = "cifs-ads"
+RCONFLICTS_cifs-doc = "cifs-ads-doc"
+RCONFLICTS_swat = "swat-ads"
+
+FILES_cifs = "${base_sbindir}/mount.cifs ${base_sbindir}/umount.cifs"
+FILES_cifs-doc = "${mandir}/man8/mount.cifs.8 ${mandir}/man8/umount.cifs.8"
+FILES_libsmbclient = "${libdir}/libsmbclient.so.*"
+FILES_libsmbclient-dev = "${libdir}/libsmbclient.so ${includedir}"
+FILES_swat       = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
+FILES_libtdb = "${libdir}/libtdb.so.*"
\ No newline at end of file
diff --git a/meta-moblin/packages/samba/samba.inc b/meta-moblin/packages/samba/samba.inc
new file mode 100644 (file)
index 0000000..ec21ed7
--- /dev/null
@@ -0,0 +1,92 @@
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS = "readline virtual/libiconv"
+
+SRC_URI = "http://samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
+           file://volatiles.03_samba \
+           file://smb.conf \
+           file://init \
+           file://tdb.pc \
+           "
+
+S = "${WORKDIR}/samba-${PV}/source"
+
+inherit autotools update-rc.d
+
+FILES_${PN}     += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat \
+                    ${libdir}/auth/*.so ${libdir}/security/*.so"
+FILES_${PN}-dbg += "${libdir}/vfs/.debug/*.so ${libdir}/charset/.debug/*.so \
+                    ${libdir}/auth/.debug/*.so ${libdir}/security/.debug/*.so"
+
+# The file system settings --foodir=dirfoo and overridden unconditionally
+# in the samba config by --with-foodir=dirfoo - even if the --with is not
+# specified!  Fix that here.  Set the privatedir to /etc/samba/private.
+EXTRA_OECONF='--disable-cups \
+              --with-readline=${STAGING_LIBDIR}/.. \
+              --with-libiconv=${STAGING_LIBDIR}/.. \
+              --without-automount \
+              --with-configdir=${sysconfdir}/samba \
+              --with-privatedir=${sysconfdir}/samba/private \
+              --with-lockdir=${localstatedir}/lock \
+              --with-piddir=${localstatedir}/run \
+              --with-logfilebase=${localstatedir}/log \
+              --with-libdir=${libdir} \
+              --with-mandir=${mandir} \
+              --with-swatdir=${datadir}/swat \
+              samba_cv_struct_timespec=yes'
+
+INITSCRIPT_NAME = "samba"
+# No dependencies, goes in at level 20 (NOTE: take care with the
+# level, later levels put the shutdown later too - see the links
+# in rc6.d, the shutdown must precede network shutdown).
+INITSCRIPT_PARAMS = "defaults"
+CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
+
+do_configure_prepend () {
+       ./script/mkversion.sh
+       if [ ! -e acinclude.m4 ]; then
+               touch aclocal.m4        
+               cat aclocal.m4 > acinclude.m4
+       fi
+}
+
+do_compile () {
+       oe_runmake proto_exists
+       base_do_compile
+}
+
+do_install_append() {
+       install -d ${D}${libdir}/pkgconfig/
+       cp ${WORKDIR}/tdb.pc ${D}${libdir}/pkgconfig/
+       mv ${D}${libdir}/libsmbclient.so ${D}${libdir}/libsmbclient.so.0 || true
+       ln -sf libsmbclient.so.0 ${D}${libdir}/libsmbclient.so
+       mkdir -p ${D}${base_sbindir}
+       rm -f ${D}${bindir}/*.old
+       rm -f ${D}${sbindir}/*.old
+       [ -f ${D}${sbindir}/mount.cifs ] && mv ${D}${sbindir}/mount.cifs ${D}${base_sbindir}/
+       [ -f ${D}${sbindir}/umount.cifs ] && mv ${D}${sbindir}/umount.cifs ${D}${base_sbindir}/
+
+       # This is needed for < 3.2.4
+       rm -f ${D}${sbindir}/mount.smbfs ${D}${base_sbindir}/mount.smbfs
+       if [ -f ${D}${bindir}/smbmount ]; then
+               ln -sf ${bindir}/smbmount ${D}${base_sbindir}/mount.smb
+               ln -sf ${bindir}/smbmount ${D}${base_sbindir}/mount.smbfs
+       fi
+       
+       install -D -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
+       install -D -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf
+       install -D -m 644 ${WORKDIR}/volatiles.03_samba ${D}${sysconfdir}/default/volatiles/volatiles.03_samba
+       install -d ${D}/var/log/samba
+       install -d ${D}/var/spool/samba
+}
+
+do_stage() {
+       install -m 0644 include/libsmbclient.h ${STAGING_INCDIR}
+       oe_libinstall -C bin -a -so libsmbclient ${STAGING_LIBDIR}
+       oe_libinstall -C bin -a -so libtdb ${STAGING_LIBDIR}
+       oe_libinstall -C bin -a -so libtalloc ${STAGING_LIBDIR}
+       oe_libinstall -C bin -so libwbclient ${STAGING_LIBDIR}
+       install -d ${STAGING_LIBDIR}/pkgconfig/
+       install -m 0644 ${WORKDIR}/tdb.pc ${STAGING_LIBDIR}/pkgconfig/
+       install -m 0644 ${S}/lib/tdb/include/*.h ${STAGING_INCDIR}/
+}
diff --git a/meta-moblin/packages/samba/samba_3.3.0.bb b/meta-moblin/packages/samba/samba_3.3.0.bb
new file mode 100644 (file)
index 0000000..c561d95
--- /dev/null
@@ -0,0 +1,35 @@
+require samba.inc
+require samba-basic.inc
+LICENSE = "GPLv3"
+
+# 3.3.0 and newer will upgrade your tdb database to a
+# new version that you can not downgrade to use with older
+# releases. More testing will happen before this is removed
+# should there be further issues. Appears to work though :)
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://configure-3.3.0.patch;patch=1 \
+            file://config-h.patch;patch=1 \
+            file://mtab.patch;patch=1 \
+               "
+
+PR = "r2"
+
+EXTRA_OECONF += "\
+       SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+       samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+       linux_getgrouplist_ok=no \
+       samba_cv_HAVE_BROKEN_GETGROUPS=no \
+       samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+       samba_cv_have_setresuid=yes \
+       samba_cv_have_setresgid=yes \
+       samba_cv_HAVE_WRFILE_KEYTAB=yes \
+       "
+
+do_configure() {
+       oe_runconf
+}
+
+do_compile () {
+       base_do_compile
+}