]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: depend on drm for 'launch' packageconfig enabled
authorAndreas Müller <schnitzeltony@googlemail.com>
Thu, 16 Jan 2014 18:09:44 +0000 (19:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 16 Jan 2014 23:39:37 +0000 (23:39 +0000)
configure fails with:

| configure:15654: checking for WESTON_LAUNCH
| configure:15661: $PKG_CONFIG --exists --print-errors "libdrm"
| Package libdrm was not found in the pkg-config search path.
| Perhaps you should add the directory containing `libdrm.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'libdrm' found
| configure:15664: $? = 1
| configure:15678: $PKG_CONFIG --exists --print-errors "libdrm"
| Package libdrm was not found in the pkg-config search path.
| Perhaps you should add the directory containing `libdrm.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'libdrm' found
| configure:15681: $? = 1
| configure:15695: result: no
| No package 'libdrm' found
| configure:15711: error: Package requirements (libdrm) were not met:
|
| No package 'libdrm' found

and configure.ac says:

| if test x$enable_weston_launch == xyes; then
|  PKG_CHECK_MODULES(WESTON_LAUNCH, [libdrm])

Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/wayland/weston_1.3.1.bb

index 8e555ee9a6194790758188836288994f19ad04de..585de66261a2e9a7dd8e3818d6d9df95bed61575 100644 (file)
@@ -47,7 +47,7 @@ PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compo
 # Weston on framebuffer
 PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev"
 # weston-launch
-PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam"
+PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam drm"
 # VA-API desktop recorder
 PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva"