]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add package to install pointercal files, and provide a pointercal for akita
authorRoss Burton <ross@openedhand.com>
Fri, 19 Jan 2007 13:08:14 +0000 (13:08 +0000)
committerRoss Burton <ross@openedhand.com>
Fri, 19 Jan 2007 13:08:14 +0000 (13:08 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1167 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/poky.conf
meta/packages/pointercal/files/akita/pointercal [new file with mode: 0644]
meta/packages/pointercal/pointercal.bb [new file with mode: 0644]

index de2a6a6c692620e32220d10c5a70c1ec44170844..65eacebed2aac27eaea627e95142df2ce76102f9 100644 (file)
@@ -189,6 +189,9 @@ DISTRO_FEATURES_cmx270 = "alsa bluetooth ext2 irda pcmcia usbgadget usbhost"
 DISTRO_EXTRA_RDEPENDS_qemuarm += "qemu-distcc"
 DISTRO_EXTRA_RDEPENDS_qemux86 += "qemu-distcc"
 
+# Pre-packaged touch screen calibration data
+DISTRO_EXTRA_RDEPENDS_akita += "pointercal"
+
 IMAGE_FEATURES ?= ""
 
 DISTRO_TASKS = "\
diff --git a/meta/packages/pointercal/files/akita/pointercal b/meta/packages/pointercal/files/akita/pointercal
new file mode 100644 (file)
index 0000000..89f407e
--- /dev/null
@@ -0,0 +1 @@
+12 -8946 33795672 12135 73 -2444604 65536
diff --git a/meta/packages/pointercal/pointercal.bb b/meta/packages/pointercal/pointercal.bb
new file mode 100644 (file)
index 0000000..a87980e
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "Touchscreen calibration data"
+SECTION = "base"
+
+PACKAGE_ARCH = ${MACHINE_ARCH}
+SRC_URI = "file://pointercal"
+S=${WORKDIR}
+
+do_install() {
+        install -d ${D}${sysconfdir}/
+        install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+}